[mythtv-users] mythfrontend on ASRock NUC

James Abernathy jfabernathy at gmail.com
Thu Aug 5 23:34:06 UTC 2021

On Thu, Aug 5, 2021 at 6:51 PM James <jam at tigger.ws> wrote:

> On 6 Aug 2021, at 6:38 am, James Abernathy <jfabernathy at gmail.com> wrote:
> On Mon, Aug 2, 2021 at 2:38 AM Stephen Worthington <
> stephen_agent at jsw.gen.nz> wrote:
>> On Sun, 1 Aug 2021 21:01:57 -0400, you wrote:
>> >I've been trying to get mythfrontend  to work properly without a ton of
>> >video tearing and shearing on my new ASRock NUC 1165G7. It's an 11th Gen
>> >Core i7 mobile part,
>> >
>> >I've tried Linux Mint 20.2, Ubuntu 21.04, PopOS and all have video
>> problems
>> >and all use the Ubuntu kernel 5.11, and Xorg server.
>> >
>> >I was having no luck getting help with this new hardware.
>> >
>> >It turns out that Kodi has the same issue using the mythtv addon. I was
>> >thinking it had to be related to older kernels or mesa drivers. I'm out
>> of
>> >my element here.
>> >
>> >Today I installed Archlinux/XFCE4 with kernel 5.13.7 and mythfrontend
>> >v31.0-162 and everything is working fine as you'd expect for this much
>> >hardware performance.  I'm using OpenGL High Quality with 4 CPUs in all
>> >this testing. Vaapi was a non-starter.
>> >
>> >I don't know what made this work. Was it the newer kernel, newer Xserver,
>> >etc.
>> >Archlinux is a lot of work to install and keep working so I'd like to
>> move
>> >back to *buntu based frontend, but not sure when this will work.
>> >
>> >Any ideas?
>> >
>> >JIm A
>> Using OpenGL should work on any distro with a modern enough CPU.
>> Getting VAAPI working might require a late enough kernel to have the
>> latest Intel video drivers suitable for the NUC.
> In the last few days the kernels and mesa software has updated across
> Kubuntu, Mint, and PopOS. So now, all work with my ASRock 1165G7 NUC.
> Jim please wax lyrical
> I 've got a gen-10 nuc but I've no idea on how to do VAAPI.
> Thanks
> James
Well on gen-11 NUC, it has something new to me called Iris GFX.  No idea if
it is good or not, but VAAPI or OpenGL in mythtv didn't work very well at
all. Both had lots of tearing in the top 20% or the screen on any motion.
It also occurred with Kodi. So I assumed it was a system software issue
like kernel or driver.

Once I got the latest Arch Linux KDE installed it worked fine with mythtv
and kodi. It didn't matter whether I chose VAAPI or OpenGL.  For the last
few years I had a Ryzen 5 3600 with a Nvidia GT1080 and it worked better
with OpenGL than NVdec. The NUC is the first Intel PC I've tested with
VAAPI for a while. I'll stick with OpenGL with 4 CPUs selected.

I just remembered I have a Dell XPS 15 9500 with a Core i7-10750H which has
hybrid graphics. both Nvidiia and Intel. I leave it in the mode that only
uses Nvidia if you turn it on for gaming, so it stays Intel GFX.

I'm running Linux Mint 20..2 with the 5.11.0-25 kernel and both High
Quality OpenGL and Normal VAAPI work well on motion, but when you start a
video on VAAPI, it flashes green for a 1/2 sec before it looks fine.  But
I've been advised by the experts on this mailing list that OpenGL works
best if the CPU is fast enough and certainly 10th and 11th gen Intel's are.

I liked the fact that Kubuntu 21.04 uses the 5.11 kernel out of the box and
updates to the stuff that works. On Linux MInt 20.2, after installation I
used the update manager to select the linux kernel 5.11.  then everything

With PopOS, it installed fine and with the latest updates mythtv works
well.  As of today all have the 5.11.0-25 kernel and a lot of mesa driver

If you have any other questions let me know.

Jim A
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20210805/3ac4a77b/attachment.htm>

More information about the mythtv-users mailing list