[mythtv-users] Screen blanking issue with NVidia 455 drivers

Erik Merkle mythtv at emerkle.net
Thu Sep 24 13:44:06 UTC 2020

I did try pressing remote buttons and keys on the keyboard to try to wake
it up, but the screen stays blank. In fact, the TV shows what it would show
for a disconnected input. I am not 100% certain, but while I was having the
problem, with the screen blank, I could press a button on my remote to
start playing Live TV. I wouldn't see or hear anything on the TV. But if I
used the keyboard to CTRL+ALT+F2 out to TTY2, then press CTRL+ALT+F1 to go
back to X, I could see whatever channel it started playing on and hear the
audio. The playback is jumpy when I do this, but stopping playback and
restarting works fine and the system is ok until the next time I turn the
TV off or stop playing content.

I did see your suggestion about the Xorg config for DPMS on another thread.
I didn't have those settings in my config, but I tried them to see and it
made no difference. On my system, I have mythfrontend started with a small
script that uses "xset" to disable the screensaver and disable DPMS:

xset s off -dpms && mythfrontend

This has worked for me for a few years now to keep the system screensaver
from kicking in and from DPMS blanking the screen for power savings. My
Xorg.conf is pretty small, and like I said, it hasn't changed for a number
of NVidia driver and kernel upgrades.

I looked briefly on the NVidia forums to see if anyone else was having a
similar issue, but didn't really find anything. At this point, I'm content
with leaving my NVidia drivers on 450.66 as it just works with those
drivers. The 455.23.04 drivers are technically beta drivers, but they are
the ones ArchLinux has as current. So for now, I'll just pin/hold back
upgrades on my NVidia drivers. I'll keep checking as NVidia and ArchLinux
update drivers and see if the problem is resolved down the road, but I have
a work-around for now.

With the limited investigation I've done so far, I'd say this is an issue
with the NVidia drivers, and not likely an issue in MythTV.

Many thanks,

On Wed, Sep 23, 2020 at 10:12 PM Stephen Worthington <
stephen_agent at jsw.gen.nz> wrote:

> On Wed, 23 Sep 2020 13:26:46 -0500, you wrote:
> >Not sure if this is the best place for this, but I am having an issue with
> >MythTV 0.31 and the latest NVidia drivers. My system is ArchLinux and the
> >latest NVidia drivers are 455.23.04.
> >
> >What I'm experiencing is that when I pause anything (live tv or videos)
> for
> >a long enough time, the output to the TV goes to sleep to the point that
> >the only way I can get it back is to use CTRL+ALT+F2 to switch to a
> virtual
> >tty, then CTRL+ALT+F1 to get back to the X display. This also is the case
> >if I turn my TV off and then immediately back on.
> >
> >I haven't touched my Xorg config in about 6 months, and things were
> working
> >fine until recently. I tried rolling back my NVidia drivers to version
> >450.66 (left Xorg config alone), rebooted and tested again and it works
> >fine, the problem goes away.
> >
> >Again, not sure if this mailing list is the appropriate place to raise
> >this, but I thought it might help anyone that happened to have the same
> >issue. For now I'll stick with the slightly older drivers and maybe check
> >the NVidia forums to see if it's a known issue.
> >
> >Thanks,
> >Erik
> Did you try just using the shift key on the keyboard, or using the IR
> remote blindly to cause a screen change?  If what you are seeing is
> DPMS blanking, either of those would cause the screen to display
> again.  Using Ctrl-Alt-F2 also works, but is more than is needed.  I
> have off and on again problems with recent Nvidia drivers and DPMS.
> Even when I have:
> Option "DPMS" "false"
> in the Monitor section of my /etc/xorf/conf file, the drivers
> sometimes disobey this and enable DPMS anyway.  When this happens, I
> have to change the DPMS option to "true" and tell DPMS that all of its
> timeouts that cause it to blank the screen are disabled:
> Section "ServerFlags"
>   Option "BlankTime"    "0"
>   Option "StandbyTime"  "0"
>   Option "SuspendTime"  "0"
>   Option "OffTime"      "0"
> EndSection
> That normally fixes this problem.
> I have had this same problem in the past with much older Nvidia
> drivers, so I have always suspected that it is triggered by some of
> the other configuration I am putting in my xorg.conf file.  Just last
> night I made a change to my xorg.conf file and had the problem come
> back again using the 450.66 drivers.  So today I am going to have to
> turn on the workaround again and reboot, when I have a gap in the
> recordings.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20200924/2bce76b3/attachment.htm>

More information about the mythtv-users mailing list