[mythtv-users] After upgrade to Ubuntu 20.04, frontend crashes X

Bob Sully malibyte56 at gmail.com
Tue Sep 22 06:39:01 UTC 2020


>>Tried to kill the pid associated with mythfrontend.real; tried both -15,
>>which didn't work, and  and -9 (which did kill it).  I didn't try using
-15
>>twice.

>Right, so it would be useful to know if 2x "kill -15" works - that
>tells us that mythfrontend is not actually locked up, it is just that
> the screen display is not working.
>You might also like to install a copy of my killm program which does
>the 2x kill -15 automatically and if mythfrontend.real does not stop
>then, goes on to do a kill -9 one second later:

>sudo su
>cd /usr/local/bin
>wget http://www.jsw.gen.nz/mythtv/killm
>chown root:root killm
>chmod u=rwx,go=rx killm

>If you do "killm x" (any non-empty parameter), it will also kill the
>mythfrontend script to stop it from automatically restarting
>mythfrontend.real.

>My best guess from the evidence so far is that the GUI is being
>started in a mode the monitor does not actually support.  There is
>long history of TVs and monitors having bad EDID data and advertising
>modes they do not actually support.  So you should be able to get
>mythfrontend.real to work well enough for you to change its GUI
>settings by using an override on the command line to put it in a
>usable mode.

>https://www.mythtv.org/wiki/Override_settings

>I have never done this, and the documentation is decidedly lacking,
>but I think you should try using a --geometry option, maybe 1920x1080
>or 1280x720.

>Another thing to try is to use xrandr from ssh.  To make xrandr work
>from ssh you have to log in as the same user that the desktop is being
>run from.  Then you can use commands like this:

>xrandr -d :0

>to access the :0 display.  That command should tell you what mode X is
>running in and what other modes it will allow you to switch to.  And
>you should be able to select a different mode (with the --mode option)
>to see if it will switch to that and start working.


Thanks again, Stephen.  I downloaded your killm utility.

Before running mythfrontend:

rcs at yoda: ~]$ xrandr
Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 16384 x 16384
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y
axis) 1872mm x 1053mm
   3840x2160     30.00*+  30.00    29.97    25.00    23.98
   1920x1080     60.00    59.94    29.97    23.98    60.00
   1600x900      60.00
   1280x1024     60.02
   1280x800      59.81
   1280x720      60.00    59.94
   1152x864      60.00
   1024x768      60.00
   800x600       60.32
   720x480       59.94
   640x480       59.94    59.93
DVI-D-1 disconnected (normal left inverted right x axis y axis)

Running mythfrontend --geometry 1920x1080+200+200 (after myth update today)
does not cause the X display to go black, as it did before; now it simply
freezes up.  Ctrl-Alt-F1 to log back in gives me the gdm login screen, but
after username/password, I now have the black screen again.  After
Ctrl-Alt-F3 and login via the CLI:

[rcs at yoda: ~]$ sudo su -
                              [sudo] password for rcs:
                                                            root at yoda:~#
killm
                  root at yoda:~# exit

Going back to the X screen -> still all black, unresponsive.

Now, after logging in via ssh from another machine OR via Ctrl-Alt-Fx from
the affected machine (same result):

[rcs at yoda: ~]$ xrandr -d :0
                            Invalid MIT-MAGIC-COOKIE-1 keyCan't open
display :0
[rcs at yoda: ~]$ xrandr
                              Can't open display

<scratching my head>
Thanks again -
Bob
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20200921/6b94214a/attachment-0001.htm>


More information about the mythtv-users mailing list