[mythtv-users] After upgrade to Ubuntu 20.04, frontend crashes X

Bob Sully malibyte56 at gmail.com
Sun Sep 20 23:23:17 UTC 2020

> I can not see anything wrong in the log.  But I am only using 20.04 on
> virtual machines at present, not on my real MythTV boxes using the
> Nvidia drivers.

> Is the crash happening just by running the mythfrontend GUI, or when
> you play a recording or video?  When you login via another TTY, is
> that using Ctrl-Alt-Fx keys to swap to a different screen, or is it
> via SSH?  What PID are you killing to try to get the screen to unblank
> - is it the mythfronted one?  If so, did you check that
> mythfrontend(.real) actually stopped?  There is a bug that means
> mythfrontend needs to be given two kill commands of the ordinary "kill
> -15" type to actually get it to stop - it mostly shuts down except for
> one final thread on the first kill -15 and the second kill -15 then
> shuts down that last thread.  Did you try kill -9 on mythfrontend?
> What distro are you running (Ubuntu, Xubuntu, ...)?  What GUI are you
> using (Gnome, XFCE4, ...)?  What display manager are you using (gdm,
> lightdm, ...)?  What sort of screen is being used (it appears to be
> 4k)?  Your video card appears to be an Nvidia GT640 running 390.138
> drivers.  I did not think that a GT640 was able to do 4k.

Hi, Stephen -
Thanks for the reply.

The screen goes completely black immediately after I fire up the GUI.  It
doesn't give me the chance to attempt to play a recording or a video.

I can log onto another tty by using Ctrl-Alt-Fx or via SSH.

Tried to kill the pid associated with mythfrontend.real; tried both -15,
which didn't work, and  and -9 (which did kill it).  I didn't try using -15

I'm using Ubuntu (was on 18.04 with Gnome; then updated to 20.04 which
apparently brought Unity back).  The display manager is gdm.

The display is an LG 32" 4K monitor.  The old reliable GT640 will do 4K,
albeit at 30 fps max.  Under 18.04, I had the GUI and playback running at
1920x1080, and after the upgrade, I changed the settings - to keep the GUI
at HD but the actual playback at 4k - I figured I'd be OK, since the video
card  does up to 30fps.   But it crashes before the GUI even comes up, so I
don't think that 4k per se is the problem - but I'm sure I could be wrong.

Thanks again for your help!

Regards -


Bob Sully
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20200920/01dd9239/attachment.htm>

More information about the mythtv-users mailing list