[mythtv-users] Metadata is generic in v31

Peter Bennett pb.mythtv at gmail.com
Sun Sep 20 16:11:26 UTC 2020


On 9/20/20 11:54 AM, Paul Gardiner wrote:
>
>
> On 20/09/2020 10:05, Paul Gardiner wrote:
>> On 20/09/2020 00:28, jam at tigger.ws wrote:>> On 20 Sep 2020, at 1:57 
>> am, Paul Gardiner <lists at glidos.net> wrote:
>>>>
>>>> I've recently updated to 31 from 29.1 and so far run into just one 
>>>> problem. Metadata looked up from within the video player is now 
>>>> generic to the series rather than specific to the episode, so I 
>>>> don't see the episode title or the description of what happens in 
>>>> the episode. There also seems to be a problem with downloading 
>>>> artwork.
>>>>
>>>> Anyone else seen similar?
>>>
>>> Paul great confusion here. It seems the movie grabber gets different 
>>> data at different times.
>>> Also I find (and this must be myth)
>>>
>>> I->Change Video->Retrieve
>>> gets generic metadata
>>>
>>> Whereas menu->scan
>>> retrivies specific data
>>>
>>> but the scan way leaves out some movies and the I way is needed. 
>>> Also the I way does not log what it is doing. I'll play with the 
>>> logging to see if I can make sense here.
>>>
>>> What we need is the developer[s] who crafted this feature to spend a 
>>> little time polishing the debugging so we can unravel what is 
>>> happening. The code is complicated and python is alien as it 
>>> contavenes my personal ethos.
>>
>> This may be wrong, but the package dependency changes suggest that 
>> there may have been a rework of the xml parsing, using a different 
>> API. When I get a chance, I'll see if I can find a corresponding 
>> commit and try to find anything that looks dodgy.
>
> Looks like the API change was 3 years ago, so I doubt that's what 
> caused the problem: I can't see it staying broken for 3 years.
>
Using V31, I have "Preform metadata update after video scan" enabled. 
After putting video files into the videos storage group on the backend, 
I run mythutil --scanvideos.  It reliably gets the descriptions of each 
episode for the series I have loaded into videos. Do you have the file 
names set up correctly? I use a directory name that is the series name 
and file names that start SnnEnn for example S01E01.  Sometimes it gets 
the same artwork for the whole series and sometimes it gets different 
artwork for each season. It rarely finds preview images.





More information about the mythtv-users mailing list