[mythtv-users] Using Webfrontend to play recording

Bob Long bob at oblong.com.au
Sat Nov 21 04:54:30 UTC 2020


James Linder wrote on 21/11/20 11:33 am:
>
>> On 19 Nov 2020, at 2:09 pm, Bob Long <bob at oblong.com.au> wrote:
>>
>> James Linder wrote on 19/11/20 12:29 pm:
>>>> On 19 Nov 2020, at 9:50 am, Bob Long <bob at oblong.com.au>
>>>>  wrote:
>>>>
>>>> Hello,
>>>>
>>>> Fresh installation of Linux Mint 20, MATE, 64 bit; MythTV fixes/31 (v31.0-v31.0) as combined backend and frontend. All that seems to work.
>>>>
>>>> So, with Firefox, trying Webfrontend|TV|Recordings; for a recording: Watch|Play in browser results in "No video with supported format..." and an instruction to install JW Player.
>>>>
>>>> Going to Menu|3rd-Party Software|JW Player and clicking on the button "Install JW Player" results in "501 not implemented."
>>>>
>>>> My searching has not resulted in a solution.
>>>>
>>>> So is this process meant to work? If so, is there a fix? Or is there another way of viewing via a browser?
>>>>
>>>>
>>> AND firefox does a crap job of streaming. I had to (dons raincoat) use chrome.
>> So I tried Google Chrome. That allowed the installation of JW Player; Firefox then knew JW Player was installed. But neither worked for "Play in Browser".
>>
>> I then tried "XSPF/M3U8/ASX" which gave a prompt; selecting VLC worked. That will do for me.
> Bob please use more words :)
Ok!
> I looked for the option and found it not.

I presume you are looking for the "XSPF/M3U8/ASX" option? To see that, I
do, in Webfrontend:

Using Firefox (not tried Google Chrome for this bit):

Webfrontend|left-hand Menu|TV|Recordings; left click on "Watch" on the
recording thumbnail. Three options appear:

Play in Browser
XSPF/M3U8/ASX
Download

Click XSPF/M3U8/ASX and Firefox prompts to open with VLC, and it does.

Firefox|Preferences|Applications has:

application/x-mpegurl type    Always ask.

I've tried this only on the combined backend/frontend so far (which in a
way is pointless, because I would usually use the proper frontend).

Bob

> I tried to use VLC directly which failed and selected uPnP, I have a server running ‘doze media player and my samsung TV see it and can use it,  but that failed too.
> James
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20201121/d1eed560/attachment.htm>


More information about the mythtv-users mailing list