[mythtv-users] RPM build of master in and for F29 - new script fails to build plugins

John Pilkington johnpilk222 at gmail.com
Tue Sep 10 14:24:30 UTC 2019

On 10/09/2019 11:08, John Pilkington wrote:
> On 09/09/2019 13:02, John Pilkington wrote:
>> On 08/09/2019 18:19, John Pilkington wrote:
>>> I ran a git pull from Gary's 'mock only' packaging site around 3 
>>> hours ago and tried an F29 build.  Building the plugins failed.
>>> It says it couldn't find rpms for mythtv-devel and python-MythTV.
>>> mythtv-devel and python2-MythTV are shown as verified and installed, 
>>> and are in the directory in tmp.
>>> ...............
>>> The problem is not with those files, but the search for dependencies 
>>> after the src.rpm has been written.  It appears to be using only the 
>>> external repos.
>>> ...........
>>> I tried again after removing all the '.rpm' suffixes in line 169 of 
>>> the BUILD_MYTHTV_RPMS script, but got much the same.  I see 'debug: 
>>> Unknown DWARF DW_OP_0' and 'DWARF version 3  in .debug aranges 
>>> unhandled' in the mythtv build log.
>>> F29 too old?
>>> ................
>>> Removing the -[!debuginfo]  bits didn't help either.  Same 
>>> complaints, but now "Nothing provides mythtv-debuginfo(x86_64)" has 
>>> apparently prevented the installs before the plugin build.
>>> Original version:
>>> mock --root=$MOCKCFG --cache-alterations --install 
>>> $TMPRESULTDIR/mythtv-devel-[!debuginfo]*.rpm 
>>> $TMPRESULTDIR/mythtv-filesystem-[!debuginfo]*.rpm 
>>> $TMPRESULTDIR/python*MythTV-[!debuginfo]*.rpm 
>>> $TMPRESULTDIR/mythtv-libs-[!debuginfo]*.rpm 
>>> $TMPRESULTDIR/mythtv-mythffmpeg-libs-[!debuginfo]*.rpm
>> ............
>> This is very strange:  it seems to be a dnf thing and nothing to do 
>> with MythTV.  'dnf install XXX*.rpm YYY*.rpm' works with local files, 
>> but 'dnf list XXX*.rpm'  or 'dnf search XXX*.rpm' search the external 
>> repos and find nothing.
>> ls -l mythtv-mythffmpeg-libs-[!debuginfo]*.rpm  works fine.
>> ...............
> It still doesn't work for me, after several tests including trying the 
> tmpfs plugin, which is suggested for use with --cache-alterations.  But 
> after combining the mock command above with the one that follows it, and 
> saving the mythtv-plugins.src.rpm before it gets wiped, I might be 
> making a little progress.
> I don't know if this is expected, but the Provides: for mythtv-devel and 
> python2-MythTV are both *100.fc29, while the 'nothing provides' 
> complaints say it's looking for *100

I was surprised to find no obvious mention of mythtv-devel in the 
specfile;  but it gets built...

The mythtv rpms installed with --allowerasing to remove the old build of 
the plugins.  The system is now running.  rpmbuild --rebuild of the 
plugins .src.rpm is missing a few exotic dependencies, and I'm inclined 
to leave it that way for the timebeing :-)

>>> John P

More information about the mythtv-users mailing list