[mythtv-users] RPM build of master in and for F29 - new script fails to build plugins

John Pilkington johnpilk222 at gmail.com
Sun Sep 8 17:19:36 UTC 2019

I ran a git pull from Gary's 'mock only' packaging site around 3 hours 
ago and tried an F29 build.  Building the plugins failed.

It says it couldn't find rpms for mythtv-devel and python-MythTV.

mythtv-devel and python2-MythTV are shown as verified and installed, and 
are in the directory in tmp.

The problem is not with those files, but the search for dependencies 
after the src.rpm has been written.  It appears to be using only the 
external repos.


I tried again after removing all the '.rpm' suffixes in line 169 of the 
BUILD_MYTHTV_RPMS script, but got much the same.  I see 'debug: Unknown 
DWARF DW_OP_0' and 'DWARF version 3  in .debug aranges unhandled' in the 
mythtv build log.

F29 too old?


Removing the -[!debuginfo]  bits didn't help either.  Same complaints, 
but now "Nothing provides mythtv-debuginfo(x86_64)" has apparently 
prevented the installs before the plugin build.

Original version:

mock --root=$MOCKCFG --cache-alterations --install 

John P

More information about the mythtv-users mailing list