[mythtv-users] FireTV 4K stick

John Pilkington johnpilk222 at gmail.com
Sun Sep 1 09:03:51 UTC 2019

On 29/08/2019 20:20, Peter Bennett wrote:
> On 8/29/19 1:50 PM, John Pilkington wrote:
>> On 29/08/2019 16:42, Peter Bennett wrote:
>>> On 8/29/19 10:44 AM, John Pilkington wrote:
>>>> $ adb connect
>>>> server version (40) doesn't match the client (41); killing...
>>>> *failed to connect
>>>> daemon started successfully
>>>> failed to connect to ''  : Connection refused
>>> When this happens use adb kill-server and try again.
>> No improvement.  At present neither adb seems to work, and logcat 
>> hangs 'waiting for device'.  Operations seem otherwise normal.  If all 
>> else fails I'll power off...
>> _______________________________________________
> Another thing, if this is a fire stick, I have found that if adb gets 
> disconnected from the fire stick by a linux reboot or suspend without 
> specifically doing "adb disconnect", sometimes the fire stick has to be 
> restarted before another adb connection is possible,

Yes; I've tried stick restarts and power-cycling, cycling the developer 
settings, and various reconnect and other options from the adb --help 
screens.  The daemon starts, but no debug connection or connection 
refused.  I haven't tried security or sideload-related tweaks.  Perhaps 
it's sulking because I haven't ordered anything.  Giving it a rest for now.

Perhaps I should put it in this thread too:  the 'rejecting' IP address 
quoted above was for the *backend*

adb connections using the IP address of the firestick still work.

John P

More information about the mythtv-users mailing list