[mythtv-users] V30 frontend on Raspberry PI3 B+

Stuart Auchterlonie stuarta at squashedfrog.net
Thu Jan 31 10:46:22 UTC 2019


On 30/01/2019 21:10, David Engel wrote:
> On Wed, Jan 30, 2019 at 03:42:27PM -0500, James Abernathy wrote:
>>
>> On 1/30/19 3:32 PM, David Engel wrote:
>>> On Mon, Jan 28, 2019 at 08:12:09PM -0500, James Abernathy wrote:
>>>> Since I now have my production system on V30 I thought I'd test the v30
>>>> mythfrontend on my RP3 B+.
>>>>
>>>> I used the standard Wiki instructions for mythtv-light on the RP3. I know
>>>> it's subjective, but I think the playback of OTA MPEG2 recordings is a
>>>> little smoother than it was on v29.1 It's still not as smooth as the Shield
>>>> TV version of v30 Mythtv-frontend, but it's close. When I'm not in test
>>>> engineer mode, I could watch it with no issues.
>>>>
>>>> However, I did manage to do something that I've not done is years, I locked
>>>> up the backend  using the frontend.  I clicked on Watch TV and the frontend
>>>> never started playing any video.  After a couple of minutes I Ctrl-Alt-F1
>>>> and logged in to reboot.  But before I messed with the RP3 again I went to
>>>> the Shield TV and it could not connect with the backend either.  So I ssh'ed
>>>> into the backend and looked at the log. Nothing unusual after the video
>>>> started and nothing until I ran "systemctl restart mythtv-backend".
>>>>
>>>> Everything recovered nicely, but no record of why the backend locked up.
>>>> When I use the systemctl restart it took about 5 minutes before it
>>>> completed. I don't know for sure because I had to leave the room. Not sure
>>>> of the version that locked up, but I had updated all mythtv software
>>>> yesterday.  While I had the backend down, I updated again today with a new
>>>> verision. (30.0+fixes-autobuild.201901261750.f11c5ab~ubuntu18.04.1). The RP3
>>>> version is mythtv-light/stretch,now 30.0-3-g44fee4bc8a-0 armhf
>>> Do you have the backend logs.  We believe we fixed a deadlock issure
>>> recently.  Note, however, that only fixes the deadlock aspect of a
>>> bigger problem.  The cause of the problem which lead to the deadlock
>>> is still unknown.
>>>
>>> David
>>
>>
>> I studied the log and it just stopped after the LiveTV streaming started. No
>> log entry part that until the backend restarted because of my systemctl
>> restart mythtv-backend.
> 
> If all logging stopped, then it's an entirely different issue.  If it
> happens again, you should run gdb and capture a backtrace.  If you
> don't have the source handy, at least have gdb generate a core dump
> for later investigation.
> 

gcore -o mythbackend-core <pid of mythbackend>

Regards
Stuart




More information about the mythtv-users mailing list