[mythtv-users] nVidia Shield (arm port maybe or just remote frontends in general) and expiring recordings

Greg Oliver oliver.greg at gmail.com
Sun Jan 13 20:50:09 UTC 2019

On Sun, Jan 13, 2019 at 2:17 PM David Engel <david at istwok.net> wrote:

> On Sun, Jan 13, 2019 at 06:59:13AM -0700, Greg Oliver wrote:
> > I was on vacation last week and got home to a very close to full disk.
> > This morning I examined some stuff and deleted a lot of stuff, but it is
> > actually not deleting anything when it says it is ::
> > [...]
> > I have deleted over 500 recordings from this Shield and modified the
> > property from 1GB free to 100GB free in settings, yet the system remains
> at
> > 3.99GB free no matter what I do.
> >
> > Long ago (the original frontend I used on the backend had the setting to
> > immediately delete files and do not delete slowly.
> >
> > I have many many TB of disk since I use my systems for work and I never
> > want mythtv managing my disk space - when I delete it - I want it gone
> > immediately (well, the current 5 minute delay is OK) - I will never have
> > issues with disk speeds when doing deletes.
> >
> > Anyone know how to fix this and get it to behave like the old frontend.
> > Here are my settings from the DB with this regard ::
> Deleted recordings are moved to the Deleted group.  They stay there
> for some amount of time (default of 1 day, minimum of 5-20 minutes,
> controllable by the DeletedMaxAge setting) before being deleted unless
> they are auto-expired or manually deleted from that group.  This
> behavior is to satisfy the people who want the ability to "undelete"
> recordings and also to avoid the "can't delete right now/the file is
> busy" issue for most users.  If you want recordings deleted ASAP,
> delete them normally, then switch to the Deleted group and delete them
> again.
> David
> --
> David Engel
> david at istwok.net

I originally deleted them all in the Normal Watch Recordings screen.  I
then changed my filter to Deleted and use the "Add to Playlist" option like
I always have and then "Playlist -> Delete Playlist".  The disappeared from
the GUI (and I did that for LiveTV as well since I watched the Cowboy game
live last night), but no space freed.

I waited 30 minutes or so and then tried to restart the backend.  This was
early - no TVs were watching anything, but it would not restart through
normal methods and systemd ended up killing it and it left a defunct
process.  I went ahead and rebooted the machine after I I stopped all of my
esxi hosts.

Whewn it came back up, it deleted stuff up to the 100GB change I made in
settings, but I *did not* go back and try all the previous stuff of
deletion since I have never had this issue before.

If what I tried should normally work, cool - if not, did I miss a step - I
have never had to do this with my old frontend - just started with the
Shield.  I would have used the frontend / backend box, but I unplugged the
mceusb receiver and bt receivers a while ago and probably tossed them
somewhere it would take a while to find :)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20190113/a7a28ac6/attachment.html>

More information about the mythtv-users mailing list