[mythtv-users] mythtranscode crashes on a .ts HD file

UB40D ub40dd at googlemail.com
Sun Jan 13 13:30:36 UTC 2019

I would like to save the edited version of a recorded file (keeping the
original). The file is a full HD recording, saved as a .ts file.

I have in the past succeeded in using mythtranscode for this purpose but
the same command that worked then failed now. The main obvious differences
I see is that when it worked it was for an SD .mpg file, and now when it
doesn' t work it's an HD .ts file.

The command line I used for the SD mpg file, which worked, is
 mythtranscode --chanid 8711 --starttime 20141231215500 --mpeg2
--honorcutlist  --outfile /mnt/st5ka1/transcoding/output.mpg

(well, it worked BUT it deleted the subtitles, which is a pain. Is there a
way of honouring the cutlist but keeping the subtitles? But that' s a
separate story.)

The command line I first used for the HD file (without even noticing that
the file was .ts) was
mythtranscode --chanid 54147 --starttime 20190112035000 --mpeg2
--honorcutlist  --outfile output.mpg

and the log ended as follows, after hundreds and hundreds of lines of "
Warning: partial frame found":

2019-01-13 13:26:05.697058 W  Warning: partial frame found!
2019-01-13 13:26:05.697092 W  Warning: partial frame found!
2019-01-13 13:26:05.697151 W  Warning: partial frame found!
2019-01-13 13:26:05.697225 W  Warning: partial frame found!
2019-01-13 13:26:05.697291 E  No more queue slots!
2019-01-13 13:26:05.708845 E  Transcoding
/mnt/st5ka1/mythtv/recordings/54147_20190112035000.ts failed

I then tried dropping the --mpeg2 flag and saving to a .ts, with this

mythtranscode --chanid 54147 --starttime 20190112035000  --honorcutlist
--outfile output.ts

and what I got was
2019-01-13 13:28:31.463995 I  Honoring the cutlist while transcoding
2019-01-13 13:28:31.464376 I  Cutlist        : 0-7833,15329-21978
2019-01-13 13:28:31.464379 I  Original Length: 21978 frames
2019-01-13 13:28:31.464382 I  New Length     : 7496 frames
2019-01-13 13:28:31.464888 N  Found video height of 1088.  This is unusual
and more than likely the video is actually 1080 so mythtranscode will treat
it as such.
2019-01-13 13:28:31.464902 N  Transcode: Looking for autodetect profile:
Autodetect from 1080i
2019-01-13 13:28:31.465021 E  Transcode: Couldn't find profile for : H.264
2019-01-13 13:28:31.465024 E  Transcoding aborted, no profile found.
2019-01-13 13:28:31.465797 E  Transcoding
/mnt/st5ka1/mythtv/recordings/54147_20190112035000.ts failed
2019-01-13 13:28:31.465810 I  Waiting for threads to exit.
2019-01-13 13:28:31.568747 I  MythCoreContext::ConnectCommandSocket():
Connecting to backend server: (try 1 of 1)
2019-01-13 13:28:31.569926 I  MythCoreContext::CheckProtoVersion(): Using
protocol version 91 BuzzOff

I note the line that says "Couldn't find profile for H.264". If such a
thing is available, how do I install it? I am on ubuntu 18.04 LTS.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20190113/3da78366/attachment.html>

More information about the mythtv-users mailing list