[mythtv-users] Diagonal video tearing on frontend

Damian myth at surr.co.uk
Sat Jan 5 16:20:35 UTC 2019


Hi All,

My main frontend, connected to my projector, is an old Liva box.

It generally works great, but I've had video tearing issues for the last 
few months. No one else in the house notices it really, but it drives me 
mad! :-)

I 'think' (could be wrong) that installing VAAPI fixed this in the past. 
However, I've tried and failed to install that several times.

Just tried again, and things look fine to me ...

vainfo:
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_1
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.1 (libva 2.1.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Bay Trail - 2.1.0
vainfo: Supported profile and entrypoints
       VAProfileMPEG2Simple            :    VAEntrypointVLD
       VAProfileMPEG2Simple            :    VAEntrypointEncSlice
       VAProfileMPEG2Main              :    VAEntrypointVLD
       VAProfileMPEG2Main              :    VAEntrypointEncSlice
       VAProfileH264ConstrainedBaseline:    VAEntrypointVLD
       VAProfileH264ConstrainedBaseline:    VAEntrypointEncSlice
       VAProfileH264Main               :    VAEntrypointVLD
       VAProfileH264Main               :    VAEntrypointEncSlice
       VAProfileH264High               :    VAEntrypointVLD
       VAProfileH264High               :    VAEntrypointEncSlice
       VAProfileH264StereoHigh         :    VAEntrypointVLD
       VAProfileVC1Simple              :    VAEntrypointVLD
       VAProfileVC1Main                :    VAEntrypointVLD
       VAProfileVC1Advanced            :    VAEntrypointVLD
       VAProfileNone                   :    VAEntrypointVideoProc
       VAProfileJPEGBaseline           :    VAEntrypointVLD

However, if I choose VAAPI playback from within MythTV, it doesn't work.

Am I missing something?

Do I need to do anything else to get VAAPI woking?

Or is there anything else that I can do to get rid of the diagonal (line 
runs top left to bottom right) video tearing?

Thanks,
Damian



More information about the mythtv-users mailing list