[mythtv-users] Transcode File swap help

Jay Harbeston (ISeePeople) jharbestonus at gmail.com
Wed Jan 2 17:01:05 UTC 2019

> On Jan 2, 2019, at 9:35 AM, Brian White <bjwhite3114 at icloud.com> wrote:
> I have been battling with a problem with transcoding, and I can’t isolate the ultimate problem.
> I have tried upgrading from 0.28 to 0.28.2 and then to the latest 0.29.1
> When I transcode from the command line or from within the mythfrontend, the .tmp file is generated properly and transcoding finishes.   The only issue is that the .tmp file does NOT get swapped into the .ts location.   The .ts file remains as the original file.    In settings, I have tried “save original file” on or off with no change.
> I am on an older Fedora version (23).
> Plenty of disk space.
> It gives an error about a “thread unable to close or finish” and a read/write thread error that I see when running from the command line directly.
> I’m away from the computer right now so I don’t have the exact output.    I have upgraded myth versions in hopes that it would self-correct, but no such luck.  Could it be a permissions error?   It creates the .tmp file fine, so doesn’t seem likely.

Sounds like a permissions problem. Check the owner of the ts file as well as the permissions, to see if they are inline with the user of the transcode.  The owner/permissions of the tmp transcoded file will assist in knowing the transcode user.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20190102/4ef4ee0b/attachment.html>

More information about the mythtv-users mailing list