[mythtv-users] deleting tuners and replacing tuners

James Abernathy jfabernathy at gmail.com
Wed Feb 13 22:56:21 UTC 2019


On 2/13/19 3:40 PM, James Abernathy wrote:
>
>
> On 2/13/19 7:44 AM, Daryl McDonald wrote:
>> You may not need to delete video sources, just assign only what you 
>> want used. The D key would probably do it, but I have no experience 
>> there.
>>
>> On Tue, Feb 12, 2019, 7:11 PM James Abernathy <jfabernathy at gmail.com 
>> <mailto:jfabernathy at gmail.com>> wrote:
>>
>>
>>     On 2/12/19 4:44 PM, Daryl McDonald wrote:
>>>
>>>
>>>     On Tue, Feb 12, 2019 at 1:49 PM Michael T. Dean
>>>     <mtdean at thirdcontact.com <mailto:mtdean at thirdcontact.com>> wrote:
>>>
>>>         On 02/12/2019 01:11 PM, James Abernathy wrote:
>>>         > It looks like I have to delete all tuners to remove any tuner.
>>>
>>>         Use DELETE, by default bound to D, to delete a single
>>>         capture card.
>>>
>>>         Mike
>>>         _______________________________________________
>>>         mythtv-users mailing list
>>>         mythtv-users at mythtv.org <mailto:mythtv-users at mythtv.org>
>>>         http://lists.mythtv.org/mailman/listinfo/mythtv-users
>>>         http://wiki.mythtv.org/Mailing_List_etiquette
>>>         MythTV Forums: https://forum.mythtv.org
>>>
>>>
>>>     Deleting a single tuner leaves a space in the tuner numbering,
>>>     if your new card is to be your only tuner and you want your new
>>>     card's tuners to be enumerated 1-4 delete all tuners in the BE
>>>     setup > capture cards, then configure the new card and tie it to
>>>     the old video source.
>>>
>>     That sounds like what I want to do.  Could I delete just one of
>>     my video sources?? I think the new tuner card will receive all
>>     the channels so I'd like to delete just the video source that has
>>     the missing channels.
>>
>>     Jim A
>>
>>
> Well this turned out to be fun and games. First my 'user' was not part 
> of the group 'video' so mythtv-setup could not open the dvb card I 
> just added. I fixed that so I could use the card.
>
> However, the video sources and input connections would not mesh up.  I 
> had 2 sets of channels in the guide. One without any schedule data and 
> those channels I could tune to.  The channels with data could not be 
> tuned to.
>
> For some reason when I did the tuner scan as part of the input 
> connection setup it number the channels 5_1, 11_1, etc. But the XMLTV 
> EPG had all the channels listed as 5.1, 11.1, etc.  This may be 
> because I had built the existing XMLTV for use with mythhdhrrecorder 
> and I followed those instructions.
>
> I seem to have it fixed by deleting everything and starting over with 
> video source, etc. I created the XMLTV using tv_grab_zz_sdjson_sqlite 
> exactly from the wiki (https://www.mythtv.org/wiki/XMLTV) and got it 
> working.
>
> Now I have to go though the schedule rules and see what got affected. 
> I can already see the previously recorded programs have messed up data 
> for the channel they were recorded on.
>
> Jim A
>
I think the channel number issues is because HDHR uses 5.1, 11.1, etc. 
Whereas Hauppauge Win-TV Quad PCI tuner card uses 5_1, 11_1, etc.

Anyway, it's fixed now, database is edited and I made sure all the right 
stuff was in the systemd files so the tuners are ready to go before the 
backend starts.

Jim A


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20190213/40ca9a51/attachment.html>


More information about the mythtv-users mailing list