[mythtv-users] v30 built from source mythfrontend error

Jim Abernathy jfabernathy at gmail.com
Fri Feb 8 21:00:03 UTC 2019


On 2/8/19 3:41 PM, Bill Meek wrote:
> On 2/8/19 2:28 PM, Jim Abernathy wrote:
>>
>> On 2/8/19 1:40 PM, Bill Meek wrote:
>
> ...
>
>>>>>>>>>> 2019-02-07 13:38:52.626013 I  RemoteFile::Exists(): looking 
>>>>>>>>>> for remote file: 
>>>>>>>>>> myth://Temp@jim-build/mythtv_video_test_HD_19000Kbps_H264.mkv
>>>>>>>>>> 2019-02-07 13:38:52.631526 E downloadRemoteFile(): 
>>>>>>>>>> DOWNLOAD_FILE returned ERROR!
>>>>>>>>>
>>>>>>>>> The Temp storage group is built-in and its location is 
>>>>>>>>> calculated at
>>>>>>>>> run time. [That's the 'Temp' between the // and @ above.]
>>>>>>>>>
>>>>>>>>> It is in your <configuration directory>/tmp (perhaps 
>>>>>>>>> $HOME/.mythtv/tmp.)
>>>>>>>>> That can be changed if $MYTHCONFDIR is set.
>>>>>>>>>
>>>>>>>>> See if that exists and can be read/written by anyone trying to 
>>>>>>>>> access it.
>>>>>>>>>
>>>>>>>> it exist and I changed it's permissions to 777
>>>>>>>>
>>>>>>>> jim at jim-build:~$ ls -l .mythtv
>>>>>>>>
> ...
>>>>>>>> drwxrwxrwx 3 jim jim 4096 Feb 7 09:35 tmp
>>>>>>>>
>>>>>>>> But the problem still exist.
>>>>>>>>
>>>>>>>
>>>>>>> Actually tried it myself. The file is downloaded to the backend.
>>>>>>> ~mythtv/.mythtv/tmp/mythtv_video_test_HD_19000Kbps_H264.mkv is
>>>>>>> where mine went.
>>>>>>>
>>>>>>> The user is mythtv.
>>>>>>
>>>>>> I check my production backend and the videos were in 
>>>>>> /home/mythtv/.mythtv/tmp.
>>>>>>
>>>>>> on my test system built from source both /home/mythtv/.mythtv/tmp 
>>>>>> and /home/jim/.mythtv/tmp have a 777 permission. Even when I copy 
>>>>>> the test video files to the .mythtv/tmp/ directory the frontend 
>>>>>> test options still locks up
>>>>>
>>>>> Hmmm, these are the built-in storage groups. I'd expect other 
>>>>> failures.
>>>>> A full log would be nice (in a pastebin, not here):
>>>>>
>>>>>     m_builtinGroups["ChannelIcons"] = GetConfDir() + "/channels";
>>>>>     m_builtinGroups["Themes"] = GetConfDir() + "/themes";
>>>>>     m_builtinGroups["Temp"] = GetConfDir() + "/tmp";
>>>>>     m_builtinGroups["Streaming"] = GetConfDir() + "/tmp/hls";
>>>>>     m_builtinGroups["3rdParty"] = GetConfDir() + "/3rdParty";
>>>>>
>>>>> Looking for a line with this in it:
>>>>>
>>>>>     SG() Error: Could not create builtin...
>>>>
>>>> I ran mythfrontend and tried the test video and captured the 
>>>> complete console log at:
>>>>
>>>> https://pastebin.com/Z0pjqgxh
>>>
>>> Good log, thanks. Do you have any storage groups built?
>>>
>>> Was expecting, at least, this:
>>>
>>>     SG(Temp): FindFile: Searching for 
>>> '/mythtv_video_test_HD_19000Kbps_H264.mkv'
>>>
>>>
>>>
>> There maybe something to that. I had said that I only had the Default 
>> group defined.  That's correct and usually when I build from the PPA 
>> it creates /var/lib/mythtv/...  with all the other groups directories 
>> defined and they are used if needed.  Usually only the default is 
>> used on my normal system. Same thing for logs. I have no 
>> /var/log/mythtv directory either.  I'm sure there must be a lot of 
>> setup still to be done, I just don't know what it is.
>>
>> I guess that's the advantage of using the PPA. Which I use in my 
>> production system.  I'm just trying to learn more and building from 
>> source is a good what to accomplish that.
>
> See if this changes the output, the result will be in /tmp:
>
>     mythfrontend --verbose file:debug,network:debug --logpath /tmp 
> --quiet

here's a link to the log from /tmp

http://paste.ubuntu.com/p/HmGXcnVcD5/

Jim A



More information about the mythtv-users mailing list