[mythtv-users] [solved] mythmusic - music dir (was; problems with ripping)

Vincent McIntyre vincent.mcintyre at gmail.com
Sat Feb 2 07:32:25 UTC 2019

On Fri, Feb 01, 2019 at 10:20:28PM -0600, Bill Meek wrote:
> >
> >I revisited the settings page where the music dir is set and found that
> >field was _empty_ again. I refilled it, went to another settings page
> >and came back, empty again.
> >
> >At first I guessed this was because I set it to the the default,
> >but trying a different directory that I know exists and myth should
> >have write access to - the field was still blank when I returned.
> >There was nothing in the frontend log.
> >
> >So this is another bug, then?
> Not sure what setting you changed, but there should be a Music
> Storage Group. Use mythtv-setup's Storage Directories editor to verify
> that it's set.

I had a dim memory of that also but I could not see a place to set
that in the frontend settings menu and 'music' isn't mentioned in

I checked mythtv-setup and sure enough there was no music storage
group set, which is weird because I think I had it set up in 0.28.
I set up the /var/lib/mythtv/music directory and was able to rip ok,
so problem solved.

The reason I went down the path I did was this
which says to go to
Utilities/Setup->Setup->Media Settings->Music Settings->General Settings

That path does exist in the frontend menus but one wonders why
the music directory option is even there if it is no longer used.

> Also, don't know what version of MythTV you're on, but any modern one
> will use the Music Storage Group.

ah I should have repeated that, v29-fixes

Anyway thanks for reminding me about the storage groups Bill.
I will see if I can get on the wiki and fix some of the outdated
information I encountered.


More information about the mythtv-users mailing list