[mythtv-users] rpm build of master: sudden new failure

Bill Meek keemllib at gmail.com
Sun Aug 4 22:20:00 UTC 2019

On 8/4/19 4:04 PM, John Pilkington wrote:
> Last week (and several times in the past month) I built rpms for master for both Fedora 29 and el7.  The builds were done in F29 using Gary B's 
> script with my normal dropping of libvpx for el7, and both mythtv systems are running well.
> Now, two commits later, the build fails.  The apparent reason is 'No space on device.'  This is presumably /tmp, which shows as 2 GB; system RAM 
> is 4 GB.  I tried a google-suggested mount -o increase to 4 GB, and also tried reverting to kernel 5.1.18 but still see the same problem. ubuntu 
> PPA shows a build at the same commit.
> Attached are the end of root.log and build.log
> root.log shows an error (can't access /var/lib/mock) but with a cryptic comment and is probably ok.   I don't think I have a saved good version.
> build.log has several 'Failed to write block' and then 'No space on device,' again with a /var reference.   I tried deleting a few old 
> recordings but saw no change.
> Ideas welcome.
> John P

The MythTV buildbot just completed builds on: master-f29-64bit and master-f28-64bit
a few minutes ago (and roughly 100 prior to that.) It doesn't appear to be a commit

*buntu user here, so I don't know if Fedora's /var/tmp is a link to /tmp, but /var/tmp
appears to be where the space issue is. df --si /var/tmp. I read the comment to be
about btrfs only, not including /var/tmp


More information about the mythtv-users mailing list