[mythtv-users] Struggles with mythgame on pi3

Rob bertaboy at gmail.com
Fri Oct 13 22:24:17 UTC 2017

On Oct 12, 2017 11:08 PM, "Stephen Worthington" <stephen_agent at jsw.gen.nz>

On Thu, 12 Oct 2017 22:36:03 -0400, you wrote:

>On Sat, Aug 5, 2017 at 10:21 PM, Rob <bertaboy at gmail.com> wrote:
>> On Mon, Jul 17, 2017 at 11:47 AM, Per Hatlevik <jakeisawake at gmail.com>
>> wrote:
>>>> I'm not normally one to self-bump, but is anyone actively using the
>>>> mythgame plug-in?
>>> I haven't used mythgame in a long time....try retropie! It is easy to
>>> start from the myth menu and is designed for the pi specifically! Also
>>> easy to configure game pads for many systems!
>> Mind if you give me a pointer for launching EmulationStation from within
>> Myth?  I've added the following to a menu config, but I can't see
>> on screen or anything registered in a log file:
>>      <button>
>>        <type>GAME</type>
>>        <text>Emulation Station</text>
>>        <action>EXEC /usr/bin/emulationstation</action>
>>     </button>
>> I'm able to execute emulationstation manually from the terminal, but no
>> dice when trying through Myth....
>Not to beat a dead horse here, but is anyone able to share / point me to a
>working script that shuts down lightdm and launches ES?  Also, how did you
>work out getting ES to restart lightdm when you exit it?  I don't mean to
>sound like an idiot, but I'm still not that familiar with Debian-based
>systems.  I've tried lifting a script from some KODI work, but that just
>seems to restart X....
>Thank you,

Since Debian is using systemd now, I would think that shutting down
lightdm would be the same as on Ubuntu:

systemctl stop lightdm

and restarting it would be:

systemctl start lightdm

After starting lightdm, if you are not set up to be automatically
logged in, you will get the login screen.  Shutting down lightdm will
shut down X and all programs running under it.

Right, I've had no problems getting ES to start when I should into the pi,
but I haven't been able to figure out a script that I can get working
correctly from Myth's menus. As a point of context, the only input devices
taking directly to the pi are flirc (with av receiver's remote controller)
and dualshock 3 controllers (either through Bluetooth or USB). The pi is in
a separate room from the tv and stored away in a cabinet with the rest of
my av gear and the only ways I interact with it are through these 2 input
decides or ssh.

 I've been getting by with executing emulationstarion via ssh, but it's not
as convenient as I'd like and fails the WAF
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20171013/6967c77a/attachment.html>

More information about the mythtv-users mailing list