[mythtv-users] HDMI – no audio GT210

Stephen Worthington stephen_agent at jsw.gen.nz
Mon Jun 20 06:22:04 UTC 2016


On Mon, 20 Jun 2016 02:49:59 +0100, you wrote:

>On 20 June 2016 at 02:32, Barry Martin <barry3martin at gmail.com> wrote:
>> Hi Folks!
>>
>>
>> Have been trying to figure out why I cannot get audio from my Mythbuntu
>> Frontend. OS = 16.04, HDMI card = GeForce 210 32- and 64-bit (same card, two
>> different Frontends). “Groups“ does list 'audio'.
>>
>>
>> With the 32-bit FE I have found there is no “Sounds” Icon in Settings
>> Manager (at Desktop) – this seems significant. Tried a bunch of on-line
>> articles to fix/correct/re-install. Nothing. (I haven't checked to see if
>> the 64-bit Frontend has the same missing icon.)
>>
>>
>> aplay -l does list both sound cards (built in and added HDMI):
>>
>> Card 0 = Nvidia, device 3, 7, 8, 9
>>
>> Card 1 = ICH9, device 0 and 4
>>
>>
>> Modified /etc/asound.conf a few ways to try all four Nvidia device options,
>> as well as a few-line config file. speaker-test -Dplug:hdmi -c2 -twav seems
>> to be happy (displays “Front left., Front right”) but no audio heard. aplay
>> -D hw:0,3 /usr/share/sounds/alsa/Noise.wav also displays to the screen but
>> no sound.
>
>When setting up an old Geforce 210 a few years ago (on Debian, fwiw)
>the card's HDMI output was muted by default and unmuting it in a mixer
>application got it working.
>
>Not saying it will work for you, but it's worth a try. Sometimes it's
>the simple things...

Yes, a look at alsamixer's output can reveal all sorts of interesting
things.  When using SPDIF output, I always have to unmute it before it
will work.  And then sometimes the automatic "alsactl save" does not
seem to happen, so I find it a good idea to do that after I have
everything working.

And then there is a new-ish bug that means that sometimes the "alsactl
restore" that is supposed to happen on boot does not work, or
something else turns off my SPDIF output.  So if I start playing a
recording and there is no sound, the first thing I do is go to a
command prompt and do an "alsactl restore" and 99% of the time it
fixes it.  Sometimes I have that problem several times in one day, and
sometimes not at all for a month or so.

Another little gotch I have is with my laptop.  When it boots, it
assumes the audio is going to the headphone jack.  I have to plug in
and unplug my headphones to get it to go to the speakers.  I am sure
there is an option somewhere to fix this, but I have never had the
time to hunt it down.

Note: The alsamixer and alsactl commands may need sudo - I run them
from a root command prompt.


More information about the mythtv-users mailing list