[mythtv-users] NVidia HDMI "Device or resource busy" when it isn't

Hika van den Hoven hikavdh at gmail.com
Thu Jun 16 02:25:38 UTC 2016


Hoi Kingsley,

Thursday, June 16, 2016, 2:58:51 AM, you wrote:

> Hey-ya,

> Occasionally I get audio failing to start when playing a video     (Mythbuntu 14, x86-64).
> It seems to happen about 30% of the time on video start.
> It doesn't seem to matter if the box was recently playing video, or sitting idle for hours.

> The mythfrontend log says:

> Jun 16 07:41:56 mediabox mythfrontend.real: mythfrontend[1532]:    
> I CoreContext tv_play.cpp:2225 (HandleStateChange) TV: Attempting   
> to change from None to WatchingVideo
> Jun 16 07:41:56 mediabox mythfrontend.real:      
> mythfrontend[1532]: I CoreContext audio/audiopulsehandler.cpp:322   
> (SuspendInternal) Pulse: PulseAudio suspend OK
> Jun 16 07:41:56 mediabox         mythfrontend.real:
> mythfrontend[1532]: E CoreContext        
> audio/audiooutputalsa.cpp:340 (GetOutputSettings) ALSA:        
> snd_pcm_open("hdmi:CARD=NVidia,DEV=1"): Device or resource busy
> Jun 16 07:41:56 mediabox mythfrontend.real:      
> mythfrontend[1532]: N CoreContext audioplayer.cpp:164      
> (ReinitAudio) AudioPlayer: Enabling Audio
> Jun 16 07:41:56 mediabox mythfrontend.real:      
> mythfrontend[1532]: I CoreContext avformatdecoder.cpp:2141      
> (ScanStreams) AFD: codec AAC has 2 channels
> Jun 16 07:41:56 mediabox mythfrontend.real:      
> mythfrontend[1532]: I CoreContext avformatdecoder.cpp:2632      
> (OpenAVCodec) AFD: Opened codec 0xfb71d40, id(AAC) type(Audio)
> Jun 16 07:41:56 mediabox mythfrontend.real:      
> mythfrontend[1532]: I CoreContext avformatdecoder.cpp:2632      
> (OpenAVCodec) AFD: Opened codec 0x1027bda0, id(H264) type(Video)
> Jun 16 07:41:56 mediabox mythfrontend.real:      
> mythfrontend[1532]: W CoreContext ringbuffer.cpp:422      
> (CalcReadAheadThresh) Enabling buffering optimisations for low       bitrate stream.
> Jun 16 07:41:56 mediabox mythfrontend.real:      
> mythfrontend[1532]: I CoreContext audio/audiooutputbase.cpp:698     
> (Reconfigure) AOBase: Resampling from 44 kHz to 48 kHz with       quality medium
> Jun 16 07:41:56 mediabox mythfrontend.real:      
> mythfrontend[1532]: I CoreContext audio/audiooutputbase.cpp:792     
> (Reconfigure) AOBase: Opening audio device      
> 'hdmi:CARD=NVidia,DEV=1' ch 2(2) sr 48000 sf signed 16 bit reenc 0
> Jun 16 07:41:56 mediabox         mythfrontend.real:
> mythfrontend[1532]: E CoreContext        
> audio/audiooutputalsa.cpp:463 (OpenDevice) ALSA:        
> snd_pcm_open("hdmi:CARD=NVidia,DEV=1"): Device or resource busy
> Jun 16 07:41:56 mediabox mythfrontend.real:      
> mythfrontend[1532]: E CoreContext audio/audiooutput.cpp:249      
> (Error) AudioOutput Error: Aborting reconfigure
> Jun 16 07:41:56 mediabox mythfrontend.real:      
> mythfrontend[1532]: N CoreContext audioplayer.cpp:157      
> (ReinitAudio) AudioPlayer: Disabling Audio, reason is: Aborting      reconfigure


> Any ideas on how to fix this?

> Could it be something to do with PulseAudio?  Should I remove it ?

> Usually just stopping and re-starting playback fixes it, but that's a PITA.

> thanks,
> -kt

>  


Unless you need pulse for for instance skype do not enable it. Myth
does not use it and actually tries to disable.
It muddies the picture no matter what causes your problem.

Tot mails,
  Hika                            mailto:hikavdh at gmail.com

"Zonder hoop kun je niet leven
Zonder leven is er geen hoop
Het eeuwige dilemma
Zeker als je hoop moet vernietigen om te kunnen overleven!"

De lerende Mens



More information about the mythtv-users mailing list