[mythtv-users] IPTV - MPEG-TS stream failed to receive bytes

Stephen Worthington stephen_agent at jsw.gen.nz
Tue Jun 14 18:52:40 UTC 2016

On Tue, 14 Jun 2016 12:24:03 -0400, you wrote:

>Basically, I am trying to use mythbackend as a PVR for a paid IPTV service,
>but the back end fails to stream any data from the URL.
>I used mythtv-setup to create an IPTV capture card using an m3u file with
>the following format:
>I successfully added the channels and program data and can see the channels
>and program data on my Kodi front end as well as in Mythweb.
>However, when I go to watch a channel live or record a program, I am not
>getting any data streaming into the buffers. I set the timeout for the card
>to 60000 ms, but it appears to only attempt the connection for a few
>seconds at most. I can open the URLs just fine in VLC and the video starts
>to play in just a few seconds.
>Here is a snippet from the back end log using --setverbose channel,record
>and --setloglevel debug:
>2016-06-13 18:25:08.621845 I [5221/5743] StreamHandler
>recorders/httptsstreamhandler.cpp:137 (DownloadStream) - HTTPReader(
>DownloadStream -- begin
>2016-06-13 18:25:08.938128 I [5221/5743] StreamHandler
>recorders/httptsstreamhandler.cpp:179 (DownloadStream) - HTTPReader(
>DownloadStream -- end
>2016-06-13 18:25:08.938189 I [5221/5743] StreamHandler
>recorders/httptsstreamhandler.cpp:114 (run) - HTTPTSSH(
>DownloadStream failed to receive bytes from
>More from the same log: http://pastebin.com/4kFuWnxR
>You can see that the entire attempt to stream the data only lasts a few
>seconds. I thought that maybe the '@' symbol was causing an issue so I
>tried to escape it using '\@', but it resulted in the same behavior.
>Here is mediainfo output from a sample stream I pulled through VLC:
>I initially tried this setup on 0.27/fixes and encountered the same issue
>so I did a fresh compile of 0.28/fixes and deleted/re-created the IPTV
>tuner and sources to the same end.
>Here is my mythbackend version:
>MythTV Version : v0.28-35-g812ec08
>MythTV Branch : fixes/0.28
>Network Protocol : 88
>Library API : 0.28.20160309-1
>QT Version : 5.6.0
>Options compiled in:
> linux release use_hidesyms using_alsa using_oss using_pulse
>using_pulseoutput using_backend using_bindings_perl using_bindings_python
>using_bindings_php using_crystalhd using_dvb using_frontend using_hdhomerun
>using_vbox using_ceton using_hdpvr using_ivtv using_joystick_menu
>using_libcec using_libcrypto using_libdns_sd using_libxml2 using_lirc
>using_mheg using_opengl using_opengl_video using_qtwebkit using_qtscript
>using_qtdbus using_taglib using_v4l2 using_x11 using_xrandr using_xv
>using_systemd_notify using_bindings_perl using_bindings_python
>using_bindings_php using_freetype2 using_mythtranscode using_opengl
>using_vaapi using_vdpau using_ffmpeg_threads using_mheg using_libass
>It seems like the back end is *trying* to open the stream, but it doesn't
>like what it is seeing so my initial thoughts were that it either doesn't
>like the URL format, or that it is receiving data that it isn't expecting...
>Should this setup theoretically work? Is there a way to get more debugging
>into to determine why the stream isn't opening?
>Any ideas are appreciated.

You can run Wireshark on the MythTV box to capture the traffic on port
8000 and see exactly what mythbackend is doing with its connection
attempt.  And do the same with VLC and see what is different.

More information about the mythtv-users mailing list