[mythtv-users] [mythtv-commits] Ticket #10792: Please bump Gentoo ebuilds to 0.25

Karl Newman newmank1 at asme.org
Fri Sep 21 18:43:29 UTC 2012

On Fri, Sep 21, 2012 at 2:40 PM, lists.md301 <lists.md301 at gmail.com> wrote:

> On Fri, Sep 21, 2012 at 12:07 AM, Karl Newman <newmank1 at asme.org> wrote:
>> I had given up on portage for mythtv but I just checked this out. The
>> myth plugins are handled differently now. Instead of installing mythmusic,
>> mythnetvision, etc., you just install the single media-plugins/mythplugins
>> package and enable the USE flags for the specific plugins you want. That
>> seems like a much simpler and better method, and closer to how upstream
>> distributes them. So in order to upgrade you'll probably have to manually
>> uninstall your media-plugins/myth* packages, set up your USE flags in
>> /etc/portage/package.use, then upgrade mythtv and install the mythplugins
>> package.
> So is this documented any place "official" (like other than your email)?
> I know I only found the interim Gentoo Portage from git directions from the
> mailing list archive (back around 0.23->0.24, during that period when the
> actual Gentoo support had gone stale), and I was really wondering how
> Gentoo ebuilds were being handled.  For myself, I'm still at 0.24-fixes and
> will probably just wait until there is some stability with the eventual
> 0.26-fixes before attempting any upgrade.

I'm sure there's nothing "official" for either Gentoo or MythTV about
switching from an overlay package to a portage package. Sorry if gave you
the impression I was involved with this change. I just looked at the new
packages based on your prompting and figured out what had changed and what
you needed to do to switch.

You're probably wise to stick with 0.24 for now. I upgraded because I had
some hardware die right at the same time as 0.25 was released and I
wanted/needed to get VAAPI working. But there are several key things that
were better in 0.24. For example, commercial flagging is almost completely
broken in 0.25 (e.g., maybe 1 or 2 breaks per show get flagged, but more
often none). I think somebody is working on that, though. Mythmusic
changed, and my previous keybindings (page up/page down to change track)
don't work any more. And 0.25 feels like it's slower to start up. Anyway,
just my 2c.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20120921/b9779bdf/attachment-0001.html>

More information about the mythtv-users mailing list