[mythtv-users] MythTV newbie questions

Nick Jenkins nickpj at gmail.com
Fri Sep 14 12:52:12 UTC 2012

Hi all,

I'm new to MythTV, coming from having previously used an aging Series-1
TiVo, and I have some MythTV questions that I'm hoping you might be able
to help me with.

Version numbers/setup details, in case it helps: Distro: MythBuntu
12.04.1 (fresh install), MythTV: 0.25 + fixes (the full version string
is: "2:0.25.2+fixes.20120906.05a3d73-0ubuntu0mythbuntu4"), configured as
a primary backend + frontend. Hardware is a HP Microserver N40L with a
"Sony PlayTV" (USB dual FTA digital tuner), HDMI out and sound are via a
MSI NVIDIA GT620 card, remote control is an Flirc USB module (which
looks just like a keyboard to the host). The channels I receive are the
free-to-air ones for Sydney/Australia, and using the EIT program data.

My questions:
* When watching something with the TiVo, if you're fast forwarding or
rewinding, and then press the play/pause button, it starts playing at
normal speed. However with MythTV, if you're fast forwarding or
rewinding, and then press the play/pause button, it pauses. (I've bound
the play/pause button to the letter 'p'). Is there some way to make
MythTV play when coming out of fast forwarding/rewind, without having to
use a separate button on the remote? More broadly, this feels the more
intuitive behaviour, so would it make sense to have play/pause toggle to
play first when viewing at a non-standard speed?

* Is there some way to bind a key to "jump back 5 seconds"? I quite miss
this function from the TiVo's remote, and would like to reproduce it.
Under Setup -> Video -> Playback Groups, I can see a "jump back" entry
set to "5", but I'm assuming this is equivalent to the "JUMPRWND/Jump
back" keybinding of "Page up", and from memory this jumps back 10

* For testing the tuner, on my main Ubuntu workstation I installed a
MythTV backend and a frontend. Once I had established the tuner was
working, I wanted to use the workstation as only a frontend, so I
uninstalled mythtvbackend. But now when I run "mythfrontend", it
repeatedly says "Could not connect to the master backend. Is it running?
Is the IP address set in for it in mythtv-setup [OK]". However I don't
have mythtv-setup installed any more, as there's no backend on the
machine any more. So I went into mythfrontend -> setup -> general, and
have confirmed that the MySQL database settings are correct (since the
same MySQL parameters work when used from the command line, such as
"mysql -h N40L -D mythconverg -u mythtv -p"). The console output from
mythfrontend is here: http://pastebin.com/raw.php?i=DJeN36PE ; it seems
to want to connect to a backend server on How do I convince
mythfrontend to look at N40L rather than localhost for the backend
server? I've tried "sudo dpkg-reconfigure mythtv-frontend", but it
didn't seem to do much. Neither did deleting ~/.mythtv . Do I need to
open a different port on the MythBuntu system? Or is it more something
on the workstation?

* Not really MythTV related, more xfce (which is the window manager
being used in MythBuntu): I don't have a mouse on the mythtv system, so
how do I open the xfce main menu using only the keyboard? E.g. In
windows, ctrl-escape will open the start menu; In Gnome, Alt-F1 will
open the Gnome menu; Does anyone know the equivalent keystroke in xfce?

* Possible bug, maybe: Here in Sydney, there are two channels both
called "ABC1" (channel 2, and channel 21). They seem to show the same
content at the same time. To my way of thinking, MythTV recording option
of: "Record at any time on channel X" means that a show will only be
recorded when broadcast on one channel - however, that is not strictly
the case. When I set a show to "Record at any time on channel ABC1" when
looking at channel 2, it tries to record the show both when it shows on
channel 2, and on channel 21 (i.e. 2 simultaneous recordings from one
channel season pass). This tends to use both tuners, so it blocks
anything else from being recorded. Instead of matching for a channel
whose name matches the string "ABC1", maybe mythtv should match on a
channel called "ABC1" with the right channel number too? Anyway, just a
suggestion, because I just disabled channel 21, and that looks to have
solved the problem I had.

Any help or guidance or pointers for any of the above will be gratefully

-- All the best,

More information about the mythtv-users mailing list