[mythtv-users] Failed to get A/V sync when using VDPAU

Richard peper03 at yahoo.com
Sun Sep 9 18:22:40 UTC 2012

On 30/08/12 23:42, Stephen Robertson wrote:
> On 30 Aug 2012 22:12, "Richard" <peper03 at yahoo.com
> <mailto:peper03 at yahoo.com>> wrote:
>  >
>  > Hi,
>  >
>  > Is anyone else having getting the error message 'Failed to get A/V
> sync' when trying to play back a recording?  I don't get it all the time
> but it's often enough that it's irritating.  It doesn't seem to matter
> whether I select HD or SD material.
>  >
>  > I'm running Mythbuntu 12.04 as a combined BE/FE with Myth
> v0.25.2-16-gd519276.  The graphics card is an NVidia GeForce 8400 GS
> using the 295.40 drivers.
>  >

<long log snipped>

>  >
>  > The line that strikes me is:
>  >
>  > The system does not have enough resources to complete the requested
> operation at this time.)
>  >
>  > from the driver.  I would say 75-80% of the time everything works
> fine, so the card is perfectly capable of handling playback.
>  >
>  > It usually gets cleared up if I exit MythFrontend and start it again.
> Sometimes that's not enough and I have to kill MythWelcome as well.
>  >
>  > Is it possible that some VDPAU resources are sometimes not being
> cleaned up properly?
>  >
>  > In this particular case, we had been watching a recording and wanted
> to watch another.  The first recording had not been a problem.  After it
> finished, I moved around the menus a bit and then got this error when I
> tried to start the next recording.
>  >
>  > Occasionally, the popup 'Failed to get A/V sync' appears and
> MythFrontend locks up completely.  I have to kill the process to
> continue.  The only thing that seems to be different in this case is
> that a tiny square appears in the top left corner of the popup, in case
> that gives anyone a clue as to what may be going wrong.
>  >
>  > If other traces are required I'll do my best to get them.  I haven't
> worked out yet exactly what causes this but it shouldn't take too long
> before it re-occurs.
>  >
>  > Any help/tips would be gratefully received!
>  >
>  > Richard.
> Nothing very useful to add other than yes I see that too. Though I'm on
> ubuntu 12.04 and 0.26. I've not had a chance to investigate very far.

As the responses have been overwhelming, there are obviously lots of 
people having this problem :)

I *do* seem to have found a cure if not the reason directly.  The paint 
engine under Setup->Appearance was set to 'Auto'.  I tried changing this 
to 'Qt' a day or two ago and since then have not had the error message 
any more (for the record and for anyone in future who searches, the 
error message was 'Failed to initialize A/V sync').

I'm aware that my video card is not the beefiest around but it seems odd 
that it sometimes works and sometimes not (although it seems to have 
become less reliable in the last week or two, which makes no sense 
because I've not consciously updated anything that could/should affect 
it).  Playing back using OpenGL worked but put a much bigger load on the 
CPU and I found I couldn't play HD recordings back above about 1.1x 
speed, whereas 1.3x or more is no problem with VDPAU.

Anyway, if others *are* having this problem, try changing the paint 
engine setting.


More information about the mythtv-users mailing list