[mythtv-users] 0.25->0.26: problems with high mem consumption and oom kils

Warpme warpme at o2.pl
Sun Sep 2 09:51:28 UTC 2012


Over week ago I moved from 0.25.2 to 0.26.
I have headless BE (no X running) + 3x diskless FE (ION1, 2G RAM).

Last week I was trying to understand what is driver significantly higher 
mem usage by 0.26.
With 0.26 I have average 300-900MB for mythbackend process as avg 950MB 
for mythfrontned.
mem issue is significant problem as it quickly decreasing WAF because 
frequent oom kills in FE (triggered when mythfrontend RSS crosses approx 

For mythfrontend I can't find any specific usage pattern leading to so 
high RSS, but during week of operation (and periodic monitoring RSS) I 
got impression RSS is high but stable except some moments when it 
"explodes" and is finished by oom killer.
Unfortunately I cant find what is trigger to this. It seems to happen in 
UI operations but also in watching movie or pictures.

For mythbackend, RSS is quite low after process start (230-300MB) but 
sometimes goes to 800-900MB and stays on that level.
This increase is sporadic and I observed it is correlated with starting 
high number of concurrent recordings - but not always.

I'll be really greatful if somebody hints me about most effective way to 
diagnose problem.

Currently I'm quite desperate as those oom kills are really frustrating 
(i.e. we have evening with friends, wathing holidays pictures, and 
expierienced 3 oom kills; yesterday during normal BluRay movie watch 
also oom :-(


-------------- next part --------------
A non-text attachment was scrubbed...
Name: warpme.vcf
Type: text/x-vcard
Size: 83 bytes
Desc: not available
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20120902/8cf97f4e/attachment.vcf>

More information about the mythtv-users mailing list