[mythtv-users] Myth 0.25.2 Problems with 0 Byte recordings and capture card configuration on Fedora16

Terry Barnaby terry at beam.ltd.uk
Fri Nov 23 18:55:11 UTC 2012

On 22/11/12 20:16, John Pilkington wrote:
> On 22/11/12 18:51, Terry Barnaby wrote:
>> I have been using MythTv since about 2004 on Fedora with lots
>> of system and mythtv updates. Currently I am using MythTv 0.25.2
>> from RPM's from RPM fusion under Fedora16 in the UK. Have
>> also tried 0.25.3. (0.26 rpm won't build due to x264 dependency issues).
>> The main server has two DVB-T interfaces a PCI card and a USB stick
>> and a PCI DVB-S2 card.
>> All was working fine until about a month ago when the system
>> started intermittently not recording programs leaving 0 byte files.
>> Not sure if it happened after a kernel update or a MythTv update.
>> I was hoping it would go away with later updates but it hasn't :(
>> Recordings on the DVB-S2 card appear fine, but recordings made on
>> either of the DVB-T tuners have problems. Signal levels/SN ratios seem
>> fine and raw  "tzap -r -c channels "BBC ONE""
>> "mplayer - < /dev/dvb/adapter0/dvr0" work fine.
>> I have tried lots of things, re-scanning, deleting the transports and
>> re-scanning, setting different capture card parameters for timeouts,
>> EIT settings etc. Nothing seems to have fixed the issues as yet.
>> Current errors in the backend log are:
>> Scheduler scheduler.cpp:2565 (HandleTuning) - Cancelling recording since
>> tuning timeout, 180 seconds, has been exceeded.
>> There is also a problem with editing/adding capture cards:
>> "Could not get card info for ..." with an ioctl error:
>> FE_GET_INFO ioctl failed (/dev/dvb/adapter0/frontend0) eno: No such
>> device (19)
>>  From looking around the latter is due to kernel changes (using
>> 3.6.6-1.fc16.i686.PAE). I suspect that this may be causing the 0 byte
>> recording issues as well.
> http://code.mythtv.org/trac/ticket/10830#comment:13
> and perhaps
> http://code.mythtv.org/trac/ticket/10217#comment:11
>> So some questions:
>> 1. Is this a known issues/issues ?
>> 2. Is there a way to fix the problem ?
>> 3. The kids are getting irate :) Any ideas ?
>> Cheers
>> Terry
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users
Many thanks John, have now got it working.

Basic reason was the networkid and transportid fields in
the dvb_multiplex tables were not set.
This was due to me scanning the exiting transports (manually entered)
as I have done for many years due to issues with neighbouring
transmitter rather than the transports being added by a full scan.
For some reason the later 0.25 release don't then fill in the
networkid and transportid fields.
So deleting all the channels and transports and then doing a
full scan worked. Well almost, for the first transponder I just entered
the frequency, this resulted in the QCAM etc fields being set to
automatic settings and no channels would tune in on this transponder.
Manually editing the database entries for this transponder fixed this.

Using the "femon -H -aX" hack worked to allow capture cards to be added.

However this all shows that mythtvsetup in 25.[23] is severely broken.
I don't know how a new user would cope...
Is 0.26 better ?

More information about the mythtv-users mailing list