[mythtv-users] Myth 0.25.2 Problems with 0 Byte recordings and capture card configuration on Fedora16

Terry Barnaby terry at beam.ltd.uk
Thu Nov 22 18:51:44 UTC 2012

I have been using MythTv since about 2004 on Fedora with lots
of system and mythtv updates. Currently I am using MythTv 0.25.2
from RPM's from RPM fusion under Fedora16 in the UK. Have
also tried 0.25.3. (0.26 rpm won't build due to x264 dependency issues).

The main server has two DVB-T interfaces a PCI card and a USB stick
and a PCI DVB-S2 card.

All was working fine until about a month ago when the system
started intermittently not recording programs leaving 0 byte files.
Not sure if it happened after a kernel update or a MythTv update.
I was hoping it would go away with later updates but it hasn't :(

Recordings on the DVB-S2 card appear fine, but recordings made on
either of the DVB-T tuners have problems. Signal levels/SN ratios seem
fine and raw  "tzap -r -c channels "BBC ONE""
"mplayer - < /dev/dvb/adapter0/dvr0" work fine.

I have tried lots of things, re-scanning, deleting the transports and
re-scanning, setting different capture card parameters for timeouts,
EIT settings etc. Nothing seems to have fixed the issues as yet.

Current errors in the backend log are:

Scheduler scheduler.cpp:2565 (HandleTuning) - Cancelling recording since tuning 
timeout, 180 seconds, has been exceeded.

There is also a problem with editing/adding capture cards:
"Could not get card info for ..." with an ioctl error:

FE_GET_INFO ioctl failed (/dev/dvb/adapter0/frontend0) eno: No such device (19)

 From looking around the latter is due to kernel changes (using 
3.6.6-1.fc16.i686.PAE). I suspect that this may be causing the 0 byte
recording issues as well.

So some questions:
1. Is this a known issues/issues ?
2. Is there a way to fix the problem ?
3. The kids are getting irate :) Any ideas ?



More information about the mythtv-users mailing list