[mythtv-users] Setting up a new backend from scratch

Harry Devine lifter89 at comcast.net
Thu Nov 22 03:56:14 UTC 2012

Mike Perkins <mikep at randomtraveller.org.uk> wrote:

>On 21/11/12 13:27, Harry Devine wrote:
>> On 11/21/2012 5:52 AM, Mike Perkins wrote:
>>> On 21/11/12 04:12, Harry%20Devine wrote:
>>>> ----- Original Message ----- From: "Igor Cicimov"
><icicimov at gmail.com> To:
>>>> "Discussion about MythTV" <mythtv-users at mythtv.org> Sent: Tuesday,
>>>> 20, 2012 3:13:26 AM Subject: Re: [mythtv-users] Setting up a new
>backend from
>>>> scratch
>>>> On 20/11/2012 6:21 PM, "Nick Rout" < nick.rout at gmail.com > wrote:
>>>>> On Tue, Nov 20, 2012 at 5:41 PM, Igor Cicimov < icicimov at gmail.com
>>>>> wrote:
>>>>>> On Tue, Nov 20, 2012 at 2:10 PM, Harry%20Devine <
>lifter89 at comcast.net >
>>>>>> wrote:
>>>>>>> Subject: Re: [mythtv-users] Setting up a new backend from
>>>>>>> On 11/19/2012 05:09 PM, Harry Devine wrote: ...
>>>>>>>> Yep, it's running, and I can login using my username &
>>>>>>> Just in case, "my username" sounds like it could be "harry", you
>>>>>>> test using "mythtv". But I suspect you know that.
>>>>>>> And, like Nick suggested, that mythtv its password exists in ALL
>>>>>>> of config.xml and mysql.txt. locate -b '\mysql.txt'
>>>>>>> Next step: mythtv-setup --logpath /tmp and exit.
>>>>>>> Then pastebinit /tmp/mythtv-setup.20121119231914.6749.log (or
>>>>>>> file was created. Post the link returned by pastebinit here. If
>>>>>>> don't have it, sudo apt-get install pastebinit (I've become a
>bit fan
>>>>>>> of it.)
>>>>>>> Yeah, my username was not mythtv. So I cleared out all of the
>>>>>>> and config.xml files (I think all of them), ran "sudo
>>>>>>> mythtv-common" as Nick suggested, let the mythtv user get a new
>>>>>>> password generated, and ran mythtv-setup again. Same result.
>When I try
>>>>>>> to log in using "mysql -u mythtv -p mythconverg", I get "ERROR
>>>>>>> (28000): Access denied for user 'mythtv'@'localhost' (using
>>>>>>> YES)".
>>>>>>> BTW, here's the pastebinit URL that you requested:
>>>>>>> http://paste.ubuntu.com/1371704
>>>>>> Log in as root/admin in mysql and grant all to mythtv user on the
>>>>>> mythconverg database:
>>>>>> $ mysql -u root -p <root_password>
>>> mysql> grant all on mythconverg.* to 'mythtv'@'localhost' identified
>>> 'mythconverg';
>>> mysql> flush privileges;
>>> mysql> quit
>>>>>> $ mysql -u mythtv -p mythconverg
>>>>>> to check if it works now. If not, you have something else messed
>up. Hope
>>>>>> you know your mysql admin password ...
>>>>>> This error in your pastebin:
>>>>>> "Can't connect to MySQL server on '' (111)"
>>>>>> indicates the database is not listening on your host IP but on
>>>>>> interface only ( Edit your /etc/my.cnf file and change
>>>>>> bind address under [mysqld] section which in your case should
>look like:
>>>>>> bind = # this might be localhost too to bind =
> or
>>>>>> if you want to listen to any interface you have configured on the
>box to
>>>>>> bind =
>>>>>> Then you need to execute the above mysql steps again for mythtv
>user for
>>>>>> the local host and EVERY other client that is going to connect to
>>>>>> backend database:
>>>>>> $ mysql -u root -p <root_password>
>>> mysql> grant all on mythconverg.* to 'mythtv'@''
>identified by
>>> 'mythconverg';
>>> mysql> grant all on mythconverg.* to 'mythtv'@'IP_frontend_1'
>identified by
>>> 'mythconverg';
>>> mysql> grant all on mythconverg.* to 'mythtv'@'IP_frontend_2'
>identified by
>>> 'mythconverg'
>>> mysql> flush privileges;
>>> mysql> quit
>>>>>> and test from the local box and remote frontends:
>>>>>> $ mysql -h -u mythtv -p mythconverg
>>>>> I really wish people wouldn't advise to go outside the package
>>>>> and configuration of the particular distro.
>>>>> Nick, I agree but since he already tried the preferred way twice
>and it
>>>>> didnt work for him maybe this one will.
>>>> Sorry, but I've tried everything that you guys have suggested, and
>I still
>>>> can't connect. When I try to log in from the command line using
>"mysql -u
>>>> mythtv -p mythconverg", I get the "access denied for user
>>>> 'mythtv'@'' error.
>>> What password were you using in your tests? If you followed the
>>> instructions *exactly* then the password you have set would be
>>> (Without the quotes of course.)
>> OK, that worked.  I did look at the mysql.txt files that I found and
>changed the
>> passwords to mythconverg and was able to connect.  I can't run
>> until I get home (I was SSH'd into my box from work). How did the
>password get
>> set to 'mythconverg' by doing those steps?  I had used Nick's
>suggestion of
>> doing "sudo dpkg-reconfigure mythtv-common" and set a password there,
>so why
>> wasn't that password being used?  Does that reconfigure NOT set the
>> password into the database?
>That's what the "identified by" clause does. You probably ought to have
>set that 
>value to the password you got when you reconfigured. It doesn't really
>so long as everything ends up consistent.
>Mike Perkins
>mythtv-users mailing list
>mythtv-users at mythtv.org

Thanks everyone for the help. I didn't realize that the identified clause was setting the password, and that wrapped me around the axle a bit.  I went ahead and gave the user a better password and just successfully ran mythtv-setup.


Sent from my Android phone with K-9 Mail. Please excuse my brevity.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20121121/340a594f/attachment.html>

More information about the mythtv-users mailing list