[mythtv-users] Autoplay subtitles?

Mark Greenwood fatgerman at gmail.com
Sun Nov 11 19:54:06 UTC 2012

On Sunday 11 Nov 2012 11:09:22 Jim Stichnoth wrote:

On Sun, Nov 11, 2012 at 8:52 AM, Mark Greenwood <fatgerman at gmail.com> wrote:

I'll try to create a sample but I don't have anywhere to upload it. On the other hand I could easily give instructions on how to create one, it takes about 30 seconds.

Sure, give me the instructions for what you did and I'll try to reproduce it.


OK, I used the mkvmerge gui (mkvtoolnix-gui packge on ubuntu). What I did was : Add an avi file and an srt file. Select the subtitle track in the 'Tracks, chapters, and tags' box and set the language to English and set 'Forced track flag' to 'yes'. I left all the other settings at the default values. Then click 'Start Muxing'. It'll create an mkv file. That's all I did. You can use mediainfo or mkvinfo to verify that that 'Forced' flag is set for the subtitles track. I'm using mkvmerge GUI version 5.1.0.

The srt files I'm using have a format that looks like the following:

00:01:05,065 --> 00:01:08,762
You are seven years old.
You are a man.

00:01:08,868 --> 00:01:11,996
Bury your first toy
and your mother's picture.

00:02:05,792 --> 00:02:09,660
The mole digs tunnels
under the earth,

00:02:09,762 --> 00:02:12,094
looking for the sun.

00:02:12,198 --> 00:02:15,497
Sometimes, he gets to the surface.

... etc etc etc

(Yeah I watch some wierd movies :) )

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20121111/ebc53451/attachment.html>

More information about the mythtv-users mailing list