[mythtv-users] Mythfilldatabase issues (solved)

Alan groups4 at dancecrave.com
Sat Nov 10 12:15:57 UTC 2012

Hi All

I thought I'd put this here in case it helps others in future (I've seem 
similar threads recently).

I have been suffering automatic mythfilldatabase issues on and off since 
0.24 where it always works on the CLI. As people have said this is 
because of some permission etc difference between your login and the 
mythtv user.

In 0.26 this was still happening so I su'd to mythtv

sudo su mythtv

and ran

mythfilldatabase -v all

It came up with the usual xmltv error 13 (the annoying one I've been 
googling for ages. But I noticed it also gave *the actual command* it 
ran to get the error:

  command=nice tv_grab_uk_rt --config-file 
'/home/mythtv/.mythtv/dvta.xmltv' --output /tmp/mythwvJ6G1, timeout=0

I ran this manually as the mythtv user and bingo - the grabber came up 
with failure to write to a tmp directory - not the one in the command 
but one in the mythtv .xmltv directory (it was owned by root).

chown mythtv:mythtv on that directory now its working perfectly :)

hope this helps someone (not trying to teach anyone to suck eggs here, 
just trying to give something back to a wonderful project / community.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20121110/1eb34dce/attachment.html>

More information about the mythtv-users mailing list