[mythtv-users] Totally screwed by software update

Lee Maisel maisel at lobo.net
Thu Nov 8 16:13:06 UTC 2012

Michael Watson wrote:
> On 8/11/2012 4:35 PM, Michael Watson wrote:
>> On 8/11/2012 4:07 PM, Lee Maisel wrote:
>>> Bill Meek wrote:
>>>> On 11/07/2012 09:36 PM, Lee Maisel wrote:
>>>> ...
>>>>> Found out mysql was messed up and wouldnt start, tried every way I 
>>>>> could think of to uninstall and
>>>>> reinstall mysql, but always end up with errors, and it won't run.
>>>> Hi;
>>>> If you'll post the errors, maybe they will point to the problem.
>>>> Typing: tailf /var/log/syslog in one window while trying to start
>>>> mysql in another has helped me in the past. Or, you can look at
>>>> the mysql error file in /var/log/mysql for hints.
>>> Here's the error from apt-get install mysql-server:
>>> Setting up mysql-server-5.5 (5.5.28-0ubuntu0.12.04.2) ...
>>> start: Job failed to start
>>> invoke-rc.d: initscript mysql, action "start" failed.
>>> dpkg: error processing mysql-server-5.5 (--configure):
>>> subprocess installed post-installation script returned error exit 
>>> status 1
>>> dpkg: dependency problems prevent configuration of mysql-server:
>>> mysql-server depends on mysql-server-5.5; however:
>>>  Package mysql-server-5.5 is not configured yet.
>>> dpkg: error processing mysql-server (--configure):
>>> dependency problems - leaving unconfigured
>>> No apport report written because the error message indicates its a 
>>> followup error from a previous failure.
>>> Errors were encountered while processing:
>>> mysql-server-5.5
>>> mysql-server
>>> E: Sub-process /usr/bin/dpkg returned an error code (1)
>> That helps.
>> http://ubuntuforums.org/showthread.php?t=1998260&page=3
> Thats the same version of mysql-server that is running on my system.  
> Check your free space on your system drive.  If have no free space (or 
> not enough free space), it will cause upgrades to have issues like this.

I've tried all those suggestions, but still get the same error.   
Apparently related to apparmor?
Nothing I do fixes it so far.   Ugh

Only using 5% of the filesystem, so disk space is not an issue.  
Thanks,  I hope we can get it figured out so I don't have to completely 
reinstall MythBuntu.


More information about the mythtv-users mailing list