[mythtv-users] show pops up End of Recording but plays through Mythweb

Ian Evans dheianevans at gmail.com
Mon Nov 5 10:28:46 UTC 2012

On Mon, Nov 5, 2012 at 4:01 AM, Ian Evans <dheianevans at gmail.com> wrote:
> On Sun, Nov 4, 2012 at 11:46 PM, Ian Evans <dheianevans at gmail.com> wrote:
>> On Sun, Nov 4, 2012 at 11:30 PM, Jim Stichnoth <stichnot at gmail.com> wrote:
>>> On Sun, Nov 4, 2012 at 6:22 PM, Ian Evans <dheianevans at gmail.com> wrote:
>>>> Sigh...okay, the same thing happened today, this time on a show that
>>>> commflagged ok and I even ran commflag again to be sure. One second in
>>>> to a 1 gig file and "end of recording" popped up. Both times it's a
>>>> show from the same channel. I just tried pulling the file in VLC and
>>>> it ran fine, so no idea why myth's internal player would have a
>>>> problem with it. As I said I've been using this handbrake job since
>>>> April 2011. Hundreds of recordings have worked with it, so not sure
>>>> why these two would fail.
>>> Any chance you have a bookmark set near the end of the recording?  From the
>>> "Watch Recordings" list, highlight the program and select:
>>>   MENU > Play from... > Play from beginning
>>> Or, when the end-of-recording dialog pops up, the key sequence:
>>>   ESCAPE > 0 > INFO > PLAY
>>> which should restart playback from the beginning.
>> Jim,
>> There is no bookmark set for this recording and it plays from the
>> beginning. I don't see any video error in the logs, the message just
>> pops up. The fill plays fine in both VLC and quicktime. Appears to be
>> a tiny bit of pixelation in the first second, but nothing that chokes
>> those players. Never seen this behaviour with the internal player
>> before.
> Okay, it happened to another recording tonight. Wish I didn't have to
> transcode but don't have another recording drive right now and getting
> low on space. Since I'm one of the people having problems with .26's
> transcode, I've been using the new lossless_cut script to convert the
> recording to an mkv and then running handbrakecli to convert them down
> to smaller mp4 files.
> It does appear to be a seektable error as it thinks the show is one
> second long. The script does contain a seektable rebuild. Just
> manually ran the rebuild on one file just know and it failed to repair
> the seektable:
> 2012-11-05 03:52:14.691083 E  Object deleted with non-zero reference count!
> 2012-11-05 03:52:33.079094 E  decoding error
>                         eno: Unknown error 541478725 (541478725)
> Rebuild completed at Mon Nov 5 03:52:33 2012
> again, this is a coin toss. did two shows back to back and one was
> fine the other now had a seektable issue. Also, again, can play the
> new file outside of myth.
> I'm curious if the lossless_cut script could be causing the seektable
> issue or if it's at the handbrake stage. will try to do some testing.

quick update: if I copy the file from the Watch Recordings dir to the
Watch Videos dir, the internal player is able to play it.

Some issues:

1) these are TV recordings being shrunk for space immediate space
savings until I can get a new 1.5-2TB drive. So I really don't want
them in my Videos dir, which is more for DVDs from my collection.

2) Still not sure why this is only happening to some recordings and
not others and why this has only started happening in the last two
weeks since I moved to .26. Had issues with mythtranscode and
mythcommflag that I didn't have before.

3) the files seektable issues cannot be fixed with mythcommflag

Hope that helps.

More information about the mythtv-users mailing list