[mythtv-users] Firewire channel change

Joe Henley joehenley at kc.rr.com
Sun Nov 4 19:39:00 UTC 2012

> Thanks for that..I did read it before,but so far no joy... 
I use firewire to change channels on the set top box which is then 
connected to a HD-PVR.  When I set up my system, I make fairly detail 
notes on what I did.  ...helps to offset the short memory of an old 
fart.  The stuff below is how I set up my firewire, perhaps you'll get 
some ideas for yours from it.

-1- Modify mythtv-setup (on the backend) to use "/usr/sbin/sa_control -w 
12000 " in the "external channel changer" field in the input connections 
set up screen (of mythtv-setup). Note the blank at the end of the line.

-2- Add:  "ExecStartPre=/usr/bin/plugctl -p 0 -n 1 "oPCR[0].n_p2p_connections=1"  to /lib/systemd/system/mythbackend.service
This is for Ferdora 16; use rc.sysinit or whatever for your system

-3- The firewire driver creates the device nodes: /dev/fw0 and /dev/fw1
           "sa_control" (and most of the utilities) need _*root*_ access to the firewire controller rom
           But Myth FE runs as user "mythtv", so sa_control doesn't work within Myth FE
           I tried:    Add the video group and the [root, minimyth, mythtv, video] users together
                        Add a /etc/udev/rules.d/80-mythtv-rules to set the owner, group and mode to:  root, root, 0666.  This will over-ride some stuff in /lib/udev/rules
                         None worked
           What worked:  Modify:  "/etc/udev/rules.d/80-mythtv.rules" as shown below  (note the "/etc")
---------------------------- snip -----------------------------------------------------------------------------------------
# Set up the firewire devices with a more helpful mode
# (Ripped off from /lib/udev/rules.d/50-udev-default.rules) <== note the "lib"
# ==========================================================   
KERNEL=="fw[0-9]", ATTR{vendor}=="0xd00d1e", ATTR{model}=="0x000001",     \
 SYMLINK+="FWire_0", MODE="0666", OWNER="mythtv", GROUP="mythtv"
KERNEL=="fw[0-9]", ATTR{units}=="*0x00a02d:0x010001*", SYMLINK+="FWire_1",    \
 MODE="0666", OWNER="mythtv", GROUP="mythtv"

         I'm not sure why FWire_0 and FWire-1 ended up with owner/group = root/root, but it works.

---------------------- snip 

Good luck!  Let uss know how it works.

Joe Henley

More information about the mythtv-users mailing list