[mythtv-users] issues installing fixes/0.26 from source...

Andy Hohenner newsgroup at hohenner.com
Sat Nov 3 06:24:49 UTC 2012


my backend's gotten flakey, so I'm in the process of building a 
replacement, installing from source (yes I prefer installing source 
rather than using an RPM / package) and am running into a problem 
installing the mythplugins,

on trying to install the mythplugins, I ran:
'git pull' - output showed pulling to latest
'./configure' - output showed all the plugins to be installed
'qmake mythplugins.pro' - no output
'make' - output ended with:
rm -f libmythbrowser.so
g++ -shared -o libmythbrowser.so main.o mythbrowser.o mythflashplayer.o 
webpage.o bookmarkmanager.o bookmarkeditor.o browserdbutil.o 
moc_mythbrowser.o moc_mythflashplayer.o moc_webpage.o 
moc_bookmarkmanager.o moc_bookmarkeditor.o -L/usr/X11R6/lib -L/usr/lib64 
-L/usr/local/lib -lXext -lXinerama -lXxf86vm -lXv -lXrandr -lX11 -lxml2 
-ldns_sd -lcrypto -lass -lpulse -ljack -lasound -lSDL -lxvidcore -lx264 
-lfaac -lva -lcrystalhd -lm -luuid -pthread -lbz2 -lz -lrt -ldl 
-lfreetype -lmp3lame -lraw1394 -liec61883 -lavc1394 -lrom1394 
-L/usr/X11R6/lib -lmythzmq -lmythnzmqt -lmythqjson -lmythbase-0.26 
-lmyth-0.26 -lmythui-0.26 -lmythupnp-0.26 -lmythservicecontracts-0.26 
-lmythavcodec -lmythavutil -lmythavformat -lmythtv-0.26 -lGL -lpthread 
-lQtWebKit -lQtSql -lQtXml -lQtOpenGL -lQtGui -lQtNetwork -lQtCore

/usr/bin/ld: cannot find -lmythzmq
collect2: error: ld returned 1 exit status

make[2]: *** [libmythbrowser.so] Error 1

make[2]: Leaving directory 

make[1]: *** [sub-mythbrowser-make_default] Error 2

make[1]: Leaving directory `/usr/src/mythtv/mythtv/mythplugins/mythbrowser'

make: *** [sub-mythbrowser] Error 2

I've tried googling for lmythzmq, the only hit I'm getting is someone 
recommending editing the Makefile in MythArchive, is there some 
dependancy that I missed?



More information about the mythtv-users mailing list