[mythtv-users] Ubuntu/Mythbuntu update problem (new thread)

Raymond Wagner raymond at wagnerrp.com
Wed May 16 21:35:23 UTC 2012

On 5/16/2012 16:59, Aaron wrote:
> First one is that the 64-bit database upgrade left me two schema
> revisions behind.

MythTV 0.25 was released on April 10th to schema revision 1299, and the 
developmental branch was updated to revision 1301 on April 13th. That's 
two schema revisions. Any chance what you were seeing was accidentally 
installing the developmental branch rather than 0.25-fixes?

> I tried reinstalling 64-bit a number of times with the same results,
> and same error 139 CTD issues every time. Could it be my hardware?
> Sure... two completely different 64-bit systems.

Exit code 139 means... invalid time zones.  You configured different 
time zones for your frontend and backend, causing the frontend to 
immediately terminate with that error.  The logs of either the frontend 
or backend would confirm.


In past versions, error 139 would be an aliased segmentation fault, or 
signal 11 (+128), however I do not believe 0.24 or 0.25 behave in that 

> My first post was the abridge version. OP doesn't have to listen to me,
> I was just offering troubleshooting advice and clearly stated it might
> or might not work for him.

The troubling issue is that the AMD64 architecture was released over 
nine years ago.  AMD and Intel both stopped shipping desktop hardware 
not capable of 64-bit operation by 2006.  AMD64 has been the primary 
architecture for use on Linux for years, and yet with over 2/3 of the 
entries on Smolt running Ubuntu 12.04, over half the users are still 
running 32-bit, and there are still blind recommendations to others to 
run 32-bit.

Running 32-bit Linux should be a last resort for either a known problem 
with a particular piece of hardware, or when all other attempts at 
resolving an error has been exhausted.

More information about the mythtv-users mailing list