[mythtv-users] mythtv 0.25-rc will not compile with gcc 4.7

Kevon mythtv at reidsresidence.com
Sat Mar 31 23:27:42 UTC 2012

On 03/31/2012 07:22 PM, Kevon wrote:
> Anyone have any luck compiling myth with gcc 4.7? I just upgraded and
> everything seems to be broken. First it was ffmeg where h264_qpel_mmx.c
> needs to be patched, which I managed to fix. Now I'm stuck on compat.h
> in libmythbase. Nothing seem to be picking up unistd.h from compat.h.
> Everything which requires a function from unistd.h fails. When I add
> unistd.h directly to the .cpp  file, it compiles fine. What am I missing
> here?

Title correction

More information about the mythtv-users mailing list