[mythtv-users] Upgrading from pre-0.22 MythTV versions

Raymond Wagner raymond at wagnerrp.com
Mon Mar 26 02:33:30 UTC 2012

On 3/25/2012 21:50, f-myth-users at media.mit.edu wrote:
> First off, what was the actual problem with upgrading between MySQL
> 5.1 and 5.5?  And if it's now fixed in master, why -not- continue
> to support that upgrade path?  Why deliberately break it?

It's my understanding the problem was less MySQL, and more changes with 
how newer versions of Qt manage access to MySQL.  Specifically, 
everything is managed as a prepared statement.  With the minimum Qt 
version requirement in 0.25, some update from prior to 0.22 was 
unintentionally broken, and so rather than rewrite it to fix the issue, 
it was simply removed.

More information about the mythtv-users mailing list