[mythtv-users] Fedora 16 - ivtv - no signal?!

Alec Leamas leamas.alec at gmail.com
Wed Mar 14 18:56:29 UTC 2012

I have updated yet another box to Fedora 16 with a Hauppage 350 pci 
card  which basically feeds /dev/video0 with a stream using the ivtv 
driver. When I run mythfrontend and tries to watch live TV, there is no 
signal at all, and thus no picture.

I'm using 24-fixes, the fedora mythtv-24.2 packages (downgrading to 24.1 
makes no difference). I have also tried a clean, new setup. Same result. 
The kernel is 3.2.9

The card looks fine, using ivtv-tune I can cat its output to a file and 
watch it (ivtv-tune... ;cat /dev/video0 > tmp.mpeg; vlc tmp.mpeg)
The frontend is most likely not involved, and both the local and a 
remote FE gives same status.
Which leaves the backend. Why on earth can't it grab the data? In the 
backend log I find

2012-03-14 19:43:11.452 TVRec(1): Changing from None to WatchingLiveTV
2012-03-14 19:43:11.500 TVRec(1): HW Tuner: 1->1
2012-03-14 19:43:11.549 LoadFromScheduler(): Error, called from backend.
2012-03-14 19:43:12.256 Channel(/dev/video0) Error: 
GetCurrentChannelNum(): Failed to find Channel
2012-03-14 19:43:12.286 Channel(/dev/video0)::TuneTo(): Error, failed to 
find channel.

but switching channel doesn't help. The connection's initial channel is OK.

I have used tvtime as a test tool earlier, but it also refuses to play, 
presenting an error about an inappropriate ioctl. vlc also has functions 
to present data from /dev/video0 which doesn't work for me, but I have 
never tried that before so I don't really know what that might mean.

Have anyone a clue out there? In particular, has something changed in 
the 3.2 kernel interfaces which neither mythtv 24-fixes  nor tvtime can 

Or is just impossible to get it working if the initial channel is wrong 
(i. e., not what's in the Connection). If so, how do I change that?


Thanks in advance...


More information about the mythtv-users mailing list