[mythtv-users] Help running mythtv-setup

James Klaas jklaas at appalachian.dyndns.org
Thu Mar 8 21:49:31 UTC 2012

On Thu, Mar 8, 2012 at 4:25 PM, Nick Rout <nick.rout at gmail.com> wrote:
> On Fri, Mar 9, 2012 at 8:19 AM, Michael T. Dean <mtdean at thirdcontact.com> wrote:
>> On 03/08/2012 01:41 PM, James Klaas wrote:
>>> On Thu, Mar 8, 2012 at 1:16 PM, R. G. Newbury wrote:
>>>> On 03/08/2012 11:13 AM, James Klaas wrote:
>>>>> Hi.  My upgrade/reinstallation of MythTV seems to be going backwards.
>>>>> I'm a little frustrated at this point.
>>>>> I keep getting sidetracked by apparently irrelevant errors.
>>>>> I removed all the database files,
>> Did you do a backup of the database?  Do you still have the mysql data
>> files?  If so, I /highly/ recommend doing a backup (to a safe,
>> re-usable, portable SQL format) before doing anything more.  Just read
>> the quick start section at:
>> http://www.mythtv.org/wiki/Database_Backup_and_Restore
>>>>>   I removed all the packages and tried
>>>>> starting over from scratch.  I reinstalled the Ubuntu packages from
>>>>> the mythbuntu packages using 0.25 since I've got a Ceton.
>>>>> When I run mythtv-setup, I get the Country/Language dialog, but
>>>>> there's no Language list.  Looking in the kern.log I see lots of
>>>>> errors about libQtCore.so.4.6.2 segfaulting.
>>>>> Can anyone help.  This should be as clean an install as installing from scratch.
>>>> This sounds more like a distro problem. You either have a bad package or
>>>> there is a missing dependency, as libQtcore is not a myth library.
>>>> Maybe back up a step: save everything, nuke the disk and start again, so
>>>> you can *really* be sure it is 'as clean an install as installing from
>>>> scratch'.
>>> I may be doing the next best thing soon and doing a dist upgrade (I'm
>>> currently running 10.04 LTS), but since this is my main home server as
>>> well wiping the disk and starting over isn't really an option.  I may
>>> take a step back and just create a dedicated mythtv server.  I had
>>> hoped to avoid that though.
>>> Since mythtv relies on the QT libraries, it seems at least
>>> peripherally related.  I've seen a few other posts regarding this
>>> error, but there was no resolution there either.
>> Sounds like you may have old mythtv libs and new mythtv libs together on
>> the same system and they aren't mixing well.
>> I recommend removing all installed mythtv packages, then looking for any
>> /usr/lib/libmyth* or /usr/lib/mythtv (and /usr/local/lib/libmyth* or
>> /usr/local/lib/mythtv ) files and then deleting them.  You can (and
>> probably should) keep /usr{,/local}/share/mythtv or /etc/mythtv files.
>> Then, reinstall the packages and things should work better.
> Now I saw a post with a similar problem (lack of language options on
> the forst setup page) and someone suggested there was a library
> package not installed.
> So what packages did you install when you re-installed myth?
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users

Just whatever was in the automatically generated list:

$apt-get install mythtv-backend-master
The following NEW packages will be installed:
  libmyth-0.25-0 libmyth-python libmythtv-perl mythtv-backend
mythtv-backend-master mythtv-common mythtv-database
mythtv-transcode-utils mythweb


More information about the mythtv-users mailing list