[mythtv-users] Adding HD tuner : Scheduling issues & playback profiles

Simon Waldman lists at firecloud.org.uk
Sun Mar 4 21:34:09 UTC 2012


On Sun, Mar 4, 2012 at 12:00,  <mythtv-users-request at mythtv.org> wrote:

> Date: Sat, 3 Mar 2012 13:13:11 -0800
> From: Yeechang Lee <ylee at pobox.com>
>
> Start reading at
> http://www.gossamer-threads.com/lists/mythtv/users/421790#421790 and
> make up your own mind.

Thanks. I found that thread... confusing ;-)

However, it gave some pointers. Here's what I did:

I set the extra priority that HD programmes get to 5, to be a little
more than the other automatic priority increments, but less than the
values that I give to things that I actually want to have priority
(which are typically at -15 or +20 and so forth).
This should hopefully mean that the scheduler prefers an HD version of
a programme over an SD version, without making much difference to
which shows are recorded.

It behaves well when HD and SD versions start at the same time. I'm
not sure what happens if the SD version starts earlier - I couldn't
find an example in the next few days to test it on.

There have been two wrinkles so far:
1. The HD tuner was the first tuner in the list, and this meant that
sometimes a high-priority SD programme would be assigned to the HD
tuner, causing it to miss a lower-priority HD programme, even though
there were plenty of spare SD tuners. I solved this by deleting and
recreating the tuners in the backend setup, making sure to add the HD
tuner *last*. This means that showings that the SD tuners can record
are assigned to them first.

2. One of the HD channels (ITV1 HD) doesn't set HDTV flags in the
programme guide. This means that things on that channel don't get the
extra priority for HD programmes. To make up for this, I increased the
channel priority for that channel. On UK Freeview either everything on
a channel is in HD or nothing is, so as I understand it this should be
functionally equivalent to having the HDTV flags set.

I hope that makes sense, and I hope that it might be useful for
anybody else in a similar situation. If I can do things better, please
let me know :-)

The playback profiles issue is still a mystery. Sometimes the HD
profile is used, sometimes the SD one seems to be active. Anyway
suggestions on that one are welcome...

-- 
Simon Waldman
swaldman at firecloud.org.uk


More information about the mythtv-users mailing list