[mythtv-users] [SOLVED] Mythbuntu 12.04 /etc/mythtv/config.xml is empty & Access denied for user 'mythtv'@'localhost'

Kingsley Turner krt at krt.com.au
Mon Jul 9 03:05:19 UTC 2012

Hi - for the archive.

Symptom: Mythweb movie artwork does not show.
Symptom: In /var/log/apache/error.log there are a bunch of errors like:

[Mon Jul 09 11:51:57 2012] [error] [client] Cannot connect to 
database: , referer:
[Mon Jul 09 11:51:57 2012] [error] [client] , referer:
[Mon Jul 09 11:51:57 2012] [error] [client] Compilation failed 
in require at /var/www/mythweb/mythweb.pl line 61., referer:
[Mon Jul 09 11:51:57 2012] [error] [client] Premature end of 
script headers: mythweb.pl, referer:
[Mon Jul 09 11:51:57 2012] [error] [client] DBI 
failed: Access denied for user 'mythtv'@'localhost' (using password: YES) at 
/usr/share/perl5/MythTV.pm line 351, referer:

(obviously the is the address of my mythtv box, yours might be 

I'm not sure what the root cause of the problem is, but I think mythweb is 
using /etc/mythtv/config.xml by default.  On my fresh installation of 
Mythbuntu 12.04 this is an empty file.  I removed the 0 byte file, and 
symlinked to the real config.xml in my configured user directory

         cd /etc/mythtv
         sudo rm config.xml
         sudo ln -sf /home/<your-user-name>/.mythtv/config.xml config.xml

Having this empty config.xml causes mythweb not to be able to connect to the 
database for the artwork.  It does seem to be able to connect for other 
things, so I'm not 100% sure what the matter is.

hope this helps someone,


More information about the mythtv-users mailing list