[mythtv-users] 0.25 Major AV sync problems

Richard peper03 at yahoo.com
Thu Jul 5 19:41:23 UTC 2012

On 19/06/12 06:24, Jean-Yves Avenard wrote:
>> I'll upload a sample when I can figure out where to upload it to. The things
>> I see are common across all DVB-T broadcasts in NZ. No difference if I
>> select AAC or AC3 audio on channels where this is possible. The problem
>> seems to be something to do with audio PTS so I guess it's independent of
>> codec type.
> it's bizarre that it's not something everyone would see

I get the feeling it has several causes (whether individually or together).

I just had another play around and found turning off 'Separate video 
modes for GUI and TV playback' seemed to cure it.  The resolution for 
both GUI and Video output were both set to 1920x1080 with the frame rate 
set to 'auto'.  I'd originally turned this setting on to handle the one 
or two US DVDs I have but I noticed that although I'm in PAL land, the 
GUI had a tendency to end up refreshing at 60Hz, which causes the TV to 
go black for a second or two whilst it re-syncs.

After turning it off and jumping backwards and forwards in a recording 
that had been getting out of sync before, everything was fine.  Then I 
turned it back on again and tried explicitly setting the frame rate to 
50Hz or 25Hz but that still gave me sync errors.  After I turned it off 
again, I was *still* getting sync errors.

Changing the deinterlace method from 'Temporal 2x' to 'Temporal 1x' also 
fixed the problem (although it doesn't look quite as good).

Then I tried running nvidia-settings and explicitly set the refresh rate 
to 'Auto'.  Now I could set the deinterlace method back to 'Temporal 2x' 
and not get sync errors.

I see the ticket (10797) has been closed and marked as fixed although I 
don't think it *is* fixed.  I think it may well be caused by several 
conditions having to be present, but in one of several combinations.  
You change one setting and think you've cured it and then something else 
changes (perhaps due to restarting the system) and the problem is back 

Regardless of all the different settings, *something* is stopping the 
audio and video getting into sync after a jump.  They're in sync when 
you first start playing and only get out of sync if you jump (whether 
manually or because of a cut-point).  If you pause playback for a few 
seconds and then unpause it, they're back in sync again and stay that 
way until the next jump so it can't just be a case of 'the hardware 
isn't up to this deinterlace method' or 'the audio buffers are too low' 
or whatever.  If that were the case, the two streams should either 
always be out of sync or possibly get progressively more out of sync.

I'll keep an eye on my system over the next few days.


More information about the mythtv-users mailing list