[mythtv-users] error loading shared library libmythzmq.so.1

R. G. Newbury newbury at mandamus.org
Tue Jul 3 17:32:45 UTC 2012

On 07/02/2012 05:41 PM, R. G. Newbury wrote:
> On 07/02/2012 03:45 PM, Gavin Hurlbut wrote:

>> This makes no sense. It builds as designed. You are doing it wrong :)
> Well shit happens Gavin. *I* don't know what went wrong. I ran my
> script. Output scrolled off the screen, and I didn't notice that error.
> It borked on another error much later (which was almost assuredly a
> consequence of the first error. I ran the script again (yes, without a
> distclean...although that should not have been necessary) and found
> problems. So what the actual error was is lost.
> Note too: this was a brand new download too: Just like the one which is
> compiling now...

Ok this really is weird. At the office, I cloned a master. I installed 
uuid, uuid-devel and libuuid-devel which caused some problems on the 
home setup.

I nuked all of the /usr/local/lib/libmyth* and ../bin/myth* files.
And started a configure...make ...make install cycle.

Got to 'make' in the zeromq....'no rule to make install'....
Did a make distclean, and started again with configure.
And this time it ran.
So there IS something going on.
At this point, I suspect that there is something left in the codebase, 
which a make distclean fixes, but *what* that could be I have no idea,

Distclean removes the makefile,,,maybe there is a bad stub left in the 
code..(not listed in trac!). The distclean forces a rebuild of the 
makefile which now works????  This is kinda improbable but the only 
explanation which seems to fit.

I've never needed a distclean on a pristine download before!


More information about the mythtv-users mailing list