[mythtv-users] Compile from source fails with configure: error: cannot link with -luuid, install uuid-dev]

R. G. Newbury newbury at mandamus.org
Mon Jul 2 14:32:01 UTC 2012

On 07/01/2012 11:44 AM, jedi wrote:
> On Tue, Jun 19, 2012 at 03:17:48PM -0500, Richard Shaw wrote:
>> On Tue, Jun 19, 2012 at 2:50 PM,  <jnissley at nissley.org> wrote:
>>> I download the latest source from github this morning and tried to compile
>>> on my fedora 15 and fedora 16 servers and the following fatal error was
>>> given.
>>> checking for uuid_generate in -luuid... no
>>> configure: error: cannot link with -luuid, install uuid-dev.
>>> make[1]: *** [zeromq/Makefile] Error 1
>>> make[1]: Leaving directory `/mythtv/mythtv/mythtv/external'
>>> make: *** [external] Error 2
>>> I looked for a package called uuid-dev and could not find one but I did
>>> install all of the uuid packages I could find.
>      Alternatively, you can probably use a search key when using your package
> installation tool. Something like "apt-get install .*uuid.*dev".
>      It's also helpful to know that -l<foo> implies something named lib<foo>.
There is definitely a problem here. I got the same error when trying to 
compile zeromq using its own configure script.
I ended up doing a 'yum install uuid* and got 7 or 8 packages....but got 
the same error.

This was all AFTER the compile had failed with a 'no rule for install' 
error in the zeromq folder. There is no Makefile made in the folder. I 
presume the Makefile in the parent (external) level is supposed to work, 
but *it don't!*.

Others here have got this to work. Pointers please! (And quickly! the 
mythbox is down!).


Oh. git clone of mythtv.git, yesterday afternoon.


More information about the mythtv-users mailing list