[mythtv-users] Can't watch TV Permission Denied opening recording file despite chmod a+rwx

John Brown jb2904 at johnbrown.com.au
Sun Jul 1 10:35:28 UTC 2012

Thanks. Problem solved. Mythtv is evidentally is sensitive to the permission of the mount point when the drive is unmounted rather than the permissions of the mounted folder. Every other program used to access the same drive uses the permissions of the mounted folder. If this is not a mythtv bug then I'd consider it to be an extremely undesireable feature!

To solve the problem, I unmounted the drive (I had to find then kill a few process that were accessing the drive to do this), and noticed the mount point (/media/data) had a user/group of root/root. Since various data and programs use the mounted drive I didn't want to change it to group 'mythtv'. Instead I changed the group of the mount point to 'users':

chgrp users /media/data

Then added the mythtv user to the 'users' group

usermod -a -G mythtv

I then rebooted as a cheats way of restarting everything and it worked!


-----Original Message-----
From: mythtv-users-bounces at mythtv.org [mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Michael Watson
Sent: Sunday, 1 July 2012 6:09 PM
To: Discussion about MythTV
Subject: Re: [mythtv-users] Can't watch TV Permission Denied opening recording file despite chmod a+rwx

On 1/07/2012 6:02 PM, John Brown wrote:
> On a new installation I can't watch TV or record if I use a 2TB HD, 
> but can if I use the boot disk, despite the recording folders on both 
> drives having a+wrx permissions.
> When trying to record to the 2TB drive the log (more attached) shows:
> (/media/data/mythtv/recordings/1003_20120611121014.mpg:-1): Opening 
> file '/media/data/mythtv/recordings/1003_20120611121014.mpg'.#012
> <http://code.mythtv.org/trac/ticket/12>#011
> <http://code.mythtv.org/trac/ticket/11>#011
> <http://code.mythtv.org/trac/ticket/11>#011
> <http://code.mythtv.org/trac/ticket/11>eno: Permission denied (13)
> However, as stated above, that folder has wide open permissions:
> $ ls -l /media/data/mythtv/
> drwxrwxrwx 2 mythtv mythtv 4096 Jun 11 12:08 recordings
> I am reporting this as a mythtv bug because every other application 
> accesses this drive without a problem. I am at a loss.
> I have attached my fstab in case mythtv is taking an exception to the 
> way I have mounted the drive. If it is, then it shouldn't be.
> If I change the recording folder to the boot SSD disk with the same 
> permissions then it works fine:
> # ls -l /users/mythtv
> total 4 drwxrwxrwx 2 mythtv mythtv 4096 Jun 13 10:12 recordings
> So the problem is something specific to mythtv accessing the 2TB HD.
Check the permissions on /media and /media/data (with the drive un mounted)

mythtv-users mailing list
mythtv-users at mythtv.org

More information about the mythtv-users mailing list