[mythtv-users] SBE is "currently not connected instead" of "currently asleep"

Michael Watson michael at thewatsonfamily.id.au
Sun Jan 22 22:51:39 UTC 2012

On 22/01/2012 1:23 AM, Herman Gerritsen wrote:
> Sorry for the late reponse. But I was busy on changing my setup to one
> without SBE's
> So now I always have two systems on when i watch videos :)
> My setup now consists of A dedicated master backend (with working
> wakeup on lan and bios timer) and a dedicated frontend that can wakeup
> my master backend (so I am happy that this works as expected, yet I
> would like a working SBE with my tuner cards)
>>      I have a similar setup using WOL, that mostly works ok.  Sometimes
>> the SBE's status, for reasons unknown will change from asleep to
>> disconnected, but mostly it works as expected.
> So you're SBE usually reports as "asleep" mine only did that for a few
> seconds and changed to "disconnected".
> Did you use scripts to shut the SBE down? or just commands as I did,
> configured from the mythtv-setup on the SBE itself?
>>      I had difficulty setting it up due to sparse documentation on what
>> the shutdown, wake, sleep commands actually do.
>>      I ended up using a wrapper script for the wake command, mainly to
>> diagnose what was actually going on, and once I got it working, I left
>> it as is.  So I have:
>>          wake command:  /usr/bin/wake_tv02.sh
>>      wake_tv02.sh
>>      --------------------
>>      #!/bin/bash
>>      logger -t "wake_tv02.sh" "Waking TV02"
>>      wakeonlan<tv02 mac address>
> Okay I just used "wakeonlan<SBE mac address>" without the wrapper I
> never tried a script I can not imagine that it would make a difference
> (so maybe I should have tried it...)
> What is the "logger -t" command?
> Greetings,
> Herman
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users

logger just puts an entry in syslog, I find it makes it easier to see if 
the command is actually being run, when the Mythlogs say it is being 
run.  Whilst debugging it, my logger command was 'logger -t "wake" 
"Waking TV02 - $@"'   This way, it logs the full command line that Myth 
runs when calling the wake command.

 From memory, I think that MythTV required the MAC Address to be quoted 
(and possibly using the full path to wakeonlan), so the wake command 
becomes     /usr/bin/wakeonlan 'xx:xx:xx:xx:xx:xx'


More information about the mythtv-users mailing list