[mythtv-users] Mythbutu 11.04 -> 11.10 breaks X-server

jk90090 jk90090 at gmail.com
Sat Jan 7 01:40:05 UTC 2012

On 1/6/12 5:11 PM, R KANNAN wrote:
> Hello,
> I had a working version of Mythbuntu 11.04 on my laptop and I gave in 
> to frequent suggestions from it to upgrade to Ubuntu 11.00 this 
> afternoon. Friday afternoon is not a good time to update. After 
> installing the updates, it restarted and I found that the X server is 
> broke.
> I can login to the consoles Alt-F1...Alt-F5 fine but the X server 
> shows a blank seen. The Myth backend seems to be running fine and so 
> is Mythweb web server (Apache). The file system seems OK but the 
> X-display flashes for a few times and there is a blank screen. I have 
> tried..
> init 3
> init 5
> to restart the X server with the same result.
> I see an error message flash by just after grub but I cannot make out 
> anything. It switches then to purple splash screen before the flashing 
> followed by
> I thought the update should not change the configuration files and so 
> should work as before.
> Any ideas?
Start with looking in your /var/log/Xorg.0.log for errors.
Next, I found Ubuntu troublesome when trying to install video drivers, 
so there could be a kernel driver mismatch or something.  apt-get update 
&& apt-get upgrade to make sure everything is updated and installed.  
For instance today I loaded Mythbuntu, which defaulted to Nvidia 175.x 
driver.  I enabled the repo for 285.x (or whatever # it is) and 
installed it, but 175 just stayed as the working driver.  I'm no Ubuntu 
expert, so there was probably a trick to getting it working, but in the 
end I just removed the 175 driver which made the nvidia-current (285) 
become the working driver.


More information about the mythtv-users mailing list