[mythtv-users] Ticket #9704 Hang/Deadlock locked

John Drescher drescherjm at gmail.com
Mon Feb 6 02:38:43 UTC 2012

>> 1. How do I debug this so that someone possibly can give me advice?
> Debugging is documented at:
>   http://www.mythtv.org/wiki/Debugging
> If you are not familiar with the tools (as you suggest later in
> your post), and the description in the above is not adequate,
> help yourself now, and others in the future, by pointing out
> what is not clear in the wiki (personally, having used all the
> tools, it is clear to me, but I understand that what is obvious
> to someone with experience in the field may not be clear to
> others).

This has helped. Although there was a sticking point. It does not seem
that there is a way to enable debugging symbols in gentoo in either of
the overlays I used. The first was the mt-mythtv which I have used for
years but during the process I moved to the ebuilds in the
MythTv/packaging on github


and although the instructions in the wiki


did not enable debugging symbols but it seems to have fixed the issue.
I will probably ask about that in a different thread.

Instead of a 50% chance of a recording causing mythbackend to deadlock
and no longer accept any connections. I have not been able to produce
this once in about 5 to 10 programs recorded. I have not tried the
frontend yet however. I have also used mythweb pretty heavily after
starting a program and that also caused a deadlock.


More information about the mythtv-users mailing list