[mythtv-users] HDMI sound works for AC3 2-channel, but not 6-channel

Jean-Yves Avenard jyavenard at gmail.com
Tue Apr 3 01:35:54 UTC 2012


On 3 April 2012 11:25, Steven Ihde <steve at x2.hamachi.us> wrote:
> Yes, I can build from source.  I'm happy to try any suggestions you have.  I
> was expecting to see a message about "downmixing" from 6 to 2 channels but I
> don't see one.

if you were running mythfrontend with -v audio, you would have seen it.

Apply the following patch and see how it works:
diff --git a/mythtv/libs/libmyth/audiooutputbase.cpp b/mythtv/libs/libmyth/audio
index 54e9371..3f0420a 100644
--- a/mythtv/libs/libmyth/audiooutputbase.cpp
+++ b/mythtv/libs/libmyth/audiooutputbase.cpp
@@ -534,7 +534,7 @@ void AudioOutputBase::Reconfigure(const AudioSettings &orig_
         if (enc)
             output_format = FORMAT_S16;  // Output s16le for AC-3 encoder
-            output_format = output_settings->BestSupportedFormat();
+            output_format = FORMAT_S16;

     if (passthru)

> Sorry I missed your earlier message asking for more logs; pasted a longer
> log segment below.
Those aren't with -v audio, so it doesn't help much

> Setting the size to 128 seems to make the first three messages go away, but
> the one about "Unable to sufficiently increase ..." remains.
if this one is still there, so should the previous lines

> In neither case do I ever see the "WriteAudio: buffer underrun" messages
> (i.e., neither when sound works nor  when it is silent), so I do not believe
> buffer underruns are the problem, but I am open to suggestion there as well.

Yes, the message is informative only, rather more of an issue with
hdmi and analog playback where you could play 6 channels LPCM audio.
In which case, ALSA's 64kB default is certainly not enough


More information about the mythtv-users mailing list